GL-Net MT300N Wireguard and Samsung Smart Hub

I have set up a connection via Wireguard to a server using the GL-Net MT300N V2. as a client. When I log on to Netflix, Amazon Prime or Sky Ticket with a mobile device via this connection, it works without any problems.
Our TV Samsung The Frame is connected via Ethernet to the router with the existing Wireguard connection. The idea is to install and use the corresponding apps on the TV via Samsung’s Smart Hub in this way.
This has already worked. After a reset of the FritzBox, which serves as the source for the Internet connection of the GL-Net MT300N, the Smart Hub no longer connects to the Samsung servers. When testing the connection, sometimes there seems to be a connection, but it is not possible to install or open the apps on the Smart TV. I suspect that the firewall on the GL-Net MT300N may be blocking something. Could this be the case?
Thank you very much for any advice.

Some apps are now accessible, but Netflix, Sky and Amazon Prime still do not work, a connection error is displayed. Is this possibly related to the DNS 8.8.8.8? At least that is displayed in the Netflix app , next to the DNS server that I have set.

You can set the dns to 8.8.8.8. Not sure if that helps.

But now the problem is Sausung hub does not work or Netflix app does not work?

The connection test for Samsung works, an Internet connection is established (with an existing VPN connection). However, the app no longer works, neither Netflix, Amazon Prime Video nor Sky. However, the ARD and ZDF Mediathek apps (german public broadcasting) work.

I had exactly the same issue on my Samsung TV, it turned out to be the date was set wrong, because I had to change the location of the TV to something that it liked. The Netflix and Amazon(and other) apps will not update if the date is incorrect. I can look at the setting in a week or two when I am home to figure out what I set it to, but it took me WEEKS to figure out that it was this simple. I am pretty sure it was a setting I set on initial power-up after a firmware install, and it never asked again, I needed to go in and find it manually, it was super frustrating, because no error pointed in this direction at all. Hope this helps

Thank you for the tip, I would be very happy about it. :smiley:

Have you checked your IPv6 settings? Last time I had some woes some online services (e.g. Disney) were misbehaving because some traffic went through the VPN and some other not (my VPN only supported IPv4).

Try disabling IPv6 completely if you do not need it.