GL-S10 can't get MQTT working

I’m just trying out a GL-S10 for the first time. I have it connected to a network (ethernet) and have updated the firmware via the tool app, and configured the MQTT broker, but I never see any messages posted to the topic. I have tried with no BLE filters, and filters for MSD, MAC and name, also tried sending commands to the command topic, and nothing ever arrives.

Is there any way to debug the device to find out what is going wrong?

  1. Is it in Scanning Mode? The BLE (green) light turns off in Scanning Mode.
  2. Is it connected a network? The Network (white) light will flash or stay on when the network is connected successfully.
  3. Is it connected to MQTT? You can try sending a command to Command Topic and see if you receive a response.

The BLE led is off, the white led is on. I get no response when I send to the command topic.

I think the current problem is that S10 did not successfully connect to the MQTT server. I had test it in my office and it works. So can you try to follow my confiruration and test again?

MQTT server address: test.mosquitto.org
MQTT port: 1883