GL-S200 - NAT64 kmod-jool package missing


Using GL-S200 with OpenWrt 21.02 (latest stable FW release) running on it

it seems like kmod-jool package, which is needed to properly run jool ipv6 nat64 functionality (jool-tools package is instead available) is missing from repo.

Can you confirm that? Any chance to get that fixed?

Any other way to enable Thread NAT64 functionality on the device?

Thank you

1 Like

Same question, also following…

Yes, we can compile it and add it to the repo.


Could you let us know when this will be added? thanks

Hi @choyster
The Thread NAT64 functionality will be auto-enabled when enabling Thread Network.
Now, S200 uses OpenThread’s native NAT64 service.
For more CLI commands, you can reference openthread/src/cli at main · openthread/openthread · GitHub

root@GL-S200:~# ot-ctl nat64 state
PrefixManager: NotRunning
Translator: NotRunning
root@GL-S200:~# ot-ctl nat64 state
PrefixManager: Active
Translator: Active

Thanks for your reply, I’ve just tried that but the nat64 command isn’t supported in the current build of the firmware for the S200.
Screenshot 2023-04-24 at 09.58.41

Perhaps this will work when @hansome adds it to the repo for us?

Any idea when we could get access to this as it’s crucial for our testing?


p.s. Thread is enabled

@ywp has helped add kmod-tool to the repo in case you need it.

Hi @choyster
We plan to release a new version of the standard firmware within this week and I’ll let you know in this post when that happens.


1 Like

Thanks, is this the repo you’re referring to?
Could you point us to any documentation/tutorials to build the firmware ourselves? I understand that a new release will be made this week but it would be good to know for future reference.

Thanks again,

yep, you can use glbuild or gl-infra-builder to build your firmware and you can follow the build step in README.
About the new firmware, we fixs some stability bugs and add some settings for thread bbr.

1 Like

Hi @choyster & @nikapov ,

We had release the new filmware for S200 - v4.1.4-0100 . You can use online upgrade or download the firmware from our download site.
If you have any questions about the new version, please feel free to post to us.


謝謝 @kelly, we’ll try out the latest version now.

Just to let you know that your fixes have worked, thank you so much for your quick responses. We have other questions regarding sharing Thread credentials, which we’ll ask in a separate conversation if needs to.

Thanks again for your help,

Thank you @kelly , will try asap and let you know.