GL-SFT1200 Opal file system becomes read only

I had just come back from work and noticed that my mounted ext4 external HD was disconnected so I tried to edit the fstab file via ssh but couldn’t! It says it is [Readonly]!

Searched for solutions but no luck because all of the solutions need permission to write some system files.

the permission for the fstab file is -rw-------

Finally I tried to do a hard reset/flash firmware via the GUI and button but no luck! It just resets to the last saved state and not the default state wherein you have to assign a router password.

Please help me


i know this is a basic suggestion:

did you try something like chmod 666 fstab

Thanks for the quick response.

Yes I have and even chown but since this is a wx function hence it did not work. Still outputs as “read only"

On at least 2 of my GL.iNet routers, one has fstab with permission -rw------ and another has fstab with permission -rw-r--r--. If you logged in as root, then you should have Read/Write access as long as Owner is root with the first -rw.

Can you check that fstab has Owner root and Group root:

I use vi and can edit fstab in both routers.

I do not work for and I am not directly associated with GL.iNet

1 Like

Yes of course when I ssh it is as root (ssh root@192……).

I did use vi of course. I can view it but can’t save it (wq) because it is “read only”

It seems that you set up exroot and then, after exroot is broken, it cannot mount the internal overlay system.

Have you tried to connect the external HD again to see if it fixes?

Reset the router and start over is also the correct way. But seems you failed to reset it.

While the router is running normally, press and hold the reset for 10 seconds (LED flashes 4 times per second) then release finger.

In ssh, just type “firstboot”. Follow the guide to clear everything, then reboot.

Okay, now I see that the whole file system is Read-only and the issue is not with the specific file permissions.

It would be interesting to what and how they have mounted:


It is best to try another reset according to the instructions from alzhao.

@wcs2228 anything unusual?

I’ll try what @alzhao has mentioned and see how it goes.


It looks like /overlay is mount Read-only (ro):

Is your /overlay rw?

The /overlay is a critical part of the system. I do not have the GL-SFT1200, but /overlay is rw on at least 2 of my other GL.iNet routers. Here is one:

Here is another:

shoot. Then that’s the problem for me. I did another reset with what alzhao has recommended but it does not reset because I think the file is ro.

I’ll find a solution unless you would suggest any?

Thanks! you’re a star!

When you performed reset using the button, did you wait until the LED flashing stopped after releasing the button, which may take a few minutes to rebuild?

You can also try reloading the firmware via UBoot, but I have not personally done that on my GL.iNet routers.

Yes, I’ve done it. It’s the same result. Anyway, I’ll try to fix overlay first and if none the UBoot is my last option. My this router has been plagued with bugs since day 1. I guess that’s why it’s cheap hehe.

Thanks again.

This is mine.
Isn’t this normal?

Almost but your /dev/ubi0_1 is rw mine is ro.

Unfortunately, I have to Uboot this baby. the root cause of this is sudden power failure which I suppose happened when I was at work.

1 Like