GL-SFT1200 showing up offline on Goodcloud even though it is online

I have deployed one (1) GL-MT2500 (Brume 2) primarily as a WireGuard Server on my home network and four (4) GL-SFT1200 (Opal) routers as WireGuard clients at four (4) remote locations. I also have one (1) GL-A1300 (Slate Plus) router I travel with.

My problem is that one GL-SFT1200 router is not showing up on the Goodcloud management website. I have set up all four (4) GL-SFT1200s precisely the same, and one of them is not showing up on the management website even though it is online and connected to the WireGuard server on the GL-MT2500.

I purchased all these GL.iNet devices because of the management website, so being unable to manage one GL-SFT1200 remotely is an issue. Luckily the one that is not functioning correctly is at a location less than 10 miles away and is not the one that is 1,200 miles away.

Here is what I have tried so far.

I have completely reset the GL-SFT1200 twice, and it appears on the Goodcloud management site until the point that set up the WireGuard client and define the switch on the router to toggle on/off the WireGuard client. Then, poof, it shows up as offline from the Goodcloud management site. This is weird since the other three (3) GL-SFT1200s were set up the same except for being given different names in the Goodcloud management website and having a unique WireGuard config file.

I can also not remove the problem GL-SFT1200 from the Goodcloud management website, regardless if it is showing up online or offline. I can’t remove it from the Goodcloud website… I have a hunch it may be related to it having issues showing up online and being unable to manage it remotely.

Any idea why this is happening? More importantly, how to fix it?

Are you able to provide device logs and the email address of your Goodcloud account?

@clannad Please check the issue.

Since I cannot remotely access the router and don’t own the building it is in, it may take a while to get the logs.

I will update this thread as soon as I can get the logs.

What email address do you want me to send the logs to?

In the meantime, can you remove the problem router from the Goodcloud management website on the back end? Maybe everything will work properly once it is reassociated with my account.

You can send me the log via private message. Or send it to
The removal feature is temporarily disabled and you will be able to remove the device next Monday.

You could pm your mac of device to me. I will check it for you.

I emailed the log files to you.

PM’ed the device’s MAC address.

Have you ever try to disable the VPN option Use VPN for all process on the router, We have check your IP of other GL-SFT1200s, seem all the SFT1200s are using the wireguard server public IP to connected the GoodCloud. Please refer to the following link for device configuration.

The “Use VPN for all process on the router” option is not enabled.

I have the router setup with a WireGuard client to connect back to my GL-MT2500, the only devices connected to the SFT1200s at each location are streaming devices.

This particular location has one Amazon Fire TV stick connected to the SFT1200, all other devices at that site go through a second router directly to the internet with a different IP address.

I have the “Internet Kill Switch” enabled under the VPN setting. I did this so that the Fire TV stick does not start using the site’s public IP address if the VPN goes down.

As I stated before, all my SFT1200s are set up precisely the same, and this is the only one that does not show up on the Goodcloud management website and cannot be remotely administered.

At this point, I am getting ready to order a new SFT1200 and return this problem one since this really should not be this hard to correct, and more importantly, the vendor I ordered it from has a 30-day return window.

I guess it’s a network issue causing the WireGuard client connection to fail. When the VPN connection fails, the cloud network becomes unreachable. To resolve this issue, you can download and install the version 3.216 firmware, which has fixed the issue of reconnection failure.

On the other hand, the network condition may be different. Try running a traceroute to the public IP of the WireGuard server. And you can try to lower the wireguard client MTU.

The problem SFT1200 was running the WireGuard client and successfully connecting to the WireGuard server without any issues, it just could not be seen on the Goodcloud website for remote administration.

If this were a firmware issue the other three SFT1200s, which were set up the same, and running the same firmware version, would exhibit the same issue, which they don’t.

As I stated in my previous message I ordered a replacement SFT1200, and it works as expected and more importantly shows up on the Goodcloud management website.

I appreciate your reply but it is a moot point now.

1 Like