GL-SFT1200 Transparent Bridge

This router is advertised on Amazon as having Brdige capabilities, but I do not see any way to set that up. I’ve even tried the latest beta v4.3.7. Is this false advertising on Amazon, or am I just totally missing something?

Hi,

I bought it for the same usage, I want to connect Ethernet-only remote devices to my LAN through a transparent Wi-Fi bridge so they are in the same subnet.

Did you manage to get more information about this ?

hi,
The Extender mode is what we usually refer to as the bridge function.By “transparent” do you mean that the device under SFT1200 is visible on the upstream router of the SFT1200?If so, you can use the Access Point mode, which will forward traffic from downstream device to upstream router without
network address translation.

Hi,

thanks for replying.

I need to connect a device which is only wired to the SFT1200’s LAN port and then connect the SFT1200 with Wi-Fi to my main access point.

The device needs to have an IP address in the same range as main router so I can’t use the SFT1200 in router mode with NAT.

I tried with Extender mode but it does not let DHCP pass through so the device can’t acquire an IP address from the main router, and this particular device does not have the option to set a static address.

I then tried to connect a PC with a static IP address instead of the device, it kind of works like I’d want but there is a lot of ping loss so the connection is not really stable.

I’ll try today in AP mode and report back.

It should work for this case. You can disconnect and reconnect the Ethernet cable so that your device get new DHCP lease.

It does not work right now in Extender mode.

I made some packet captures on both the test PC and the main DHCP server, they show the DHCP requests do not get through to the main DHCP server so it does not get any reply on the test PC.

Maybe the DHCP server is still listening on SFT1200, is there a way to make it pass through ?

I have just tested SFT1200 v4.3.7

It does bridge in extender mode. Just need to wait the wifi is connected and replug the Ethernet cable.

I think you may reset the SFT1200 network and configure again.

I did unplug/replug quite a few times doing captures at the same time, DHCP requests do not get through.

It does work with a static IP address, so I know for sure Wi-Fi is connected and trafic from the test PC can reach the main router.

I also tried disabling dnsmasq, odhcpd and firewall (/etc/init.d/xxxx disable then /etc/init.d/xxxx stop), to no avail.

Can you just reset the router’s firmware and try set up extender without changing other settings manually? This is what I did. You should not touch the dnsmasq and odhcpd, firewall etc.

That’s what I did at the beginning, I only tried messing with other settings when it did not work.

I just noticed I’m running v3.216, and it does not want to upgrade online. Do I have to download and apply a v4 firmware manually ?

Pls upgrade manually without settings kept then try again.

Same with 4.3.7.

I did
. reset to factory settings
. downloaded and applied beta v4.3.7
. configured the SFT1200 in Extender Mode
. made sure Wi-Fi was connected
. unplug/plug Ethernet cable

and still the DHCP Discover packets are sent but they do not reach the main DHCP server.

Again, it works with a static IP address on the test PC so I know everything is connected (and throughput measured with iperf is better in 4.3.7 than in v3.216).

So I did some more tests, I can get an adress from my DHCP server if and only if the Wi-Fi SSID is on the main router.

On my network, router, Wi-Fi and DHCP server are on different devices.

The main router is my ISP’s router, Wi-Fi is handled by Ruckus APs and DHCP by RaspberryPi running Pihole.

If I configure the main router to advertise a separate Wi-Fi SSID and I connect to this network, then the test PC behind the SFT1200 receives a DHCP lease from Pihole.

Seems the SFT1200 does something, is there a way to make it a real transparent bridge ?

Frustrating experience with this product, seemed promising at first but behaves strangely when you want to use it as a transparent bridge.
I will return it for a refund.