GL-SFT1200 - USB android tethering + XBox = nat /upnp issues

Sorry if this has been talked about but on one thread related to the old 300AR/MT units someone mentioned downgrading firmware to fix the nat/upnp issues related to usb tethering and using a xbox one for multiplayer. Since I have the GL-SFT1200 unit downgrading to that firmware isn’t an option.

Does anyone know of a work around? I tried enabling the ports and dmz zone for the xbox but it still won’t get online. Any help is greatly appreciated. Trying to be able to live stream from my xbox and I can’t with my dsl slow poke connection.

As far as I know you can’t stop the nat errors to the point where it says “open”. The best you’ll get is “moderate”. I have the same issue when using a phone USB tether. It seems to be the phone causing it.

All I’m trying for is moderate… right now the xbox won’t even let me use the GL router with my phone tethered. what did you do to get moderate and get yours online? disable ipv6? port forward? I can use the phone’s hotspot directly via xbox… it’s happening because of double nat… need to know what I can do to bypass the issue… whether it’s port forwarding, enabling ip passthrough, etc.

The gli should sort its own connection between it and the outside world but make sure your LAN IP is DIFFERENT NETWORK but on the same subnet.

EG my gli to phone connection could be, the gli internal LAN IP and DHCP pool should be on another network and SAME subnet like All devices within use that pool.

If you have another router between the gli an outside then you need to put the gli LAN IP into THAT routers DMZ OR activate UPNP/open ports.

Gateways point to the next router, not the overall Point Of Entry. DNS points to the POE.

Hope this helps.

shouldn’t upnp already be active on the SFT1200? I just got my SFT1200 from amazon so I can trouble shoot the device locally with my ps4 and my phone… hopefully I can get it working locally and just implement what I did with my God son’s remotely.

Have you tried tethering from your phone with a usb C to ethernet adapter with a PD charge port? It shows up in the phones tethering section as an ethernet tethering option.

UPNP may not be enabled by default. To enable, you may need to install luci and luci-app-upnp and enable it.

But one more thing to check is that does your carrier only give you IPV6 address? If yes then it may cause xbox fail which relays in IPV4.

I enabled dmz on the GL router for the xbox. Seems to work but the checks still fail for upnp on the xbox testing… Guess it’s fine. The party chat works as well as Warzone game chat.

1 Like