GL-X3000 Dropping Bands

I’ve been using the GL-X3000 for about two weeks now, playing around with it and learning the device. For the most part it works fine. For context, I’m using the Visible cellular network, which is based on Verizon’s network, so I use the APN “VZWINTERNET” with a TTL of 88. Unfortunately, even after adjusting both of these variables numerous ways, I still drop bands. It’s very confusing as I can fully disconnect and reconnect, and then I get back those two bands. I’ve tried blocking bands, opening bands, locking onto a specific tower, but no, it never maintains the three bands. For the most part, the best speeds I’ve experienced are the bands 66, 13, and 2, all in combination, but 2/3 always drop, so I can’t experience those good speeds. Anyone have experience with this? I’ve been doing a lot of searching and trying new things, but it never changes. I’ve tried various firmware versions as well. Thanks.

The specific phenomenon will fall from 5G to 4G?
Or will it switch from 66, 13, 2 to another band and cause the speed to drop

I would start with making sure the modem firmware is at RM520NGLAAR03A03M4G_01.201.01.201
This is different than updating the router firmware.
I am using a Verizon SIM on my router, and this modem firmware improved many things with Verizon for me.
My router will still occasionally choose a band that is slower…I think because it has a stronger signal.
I can lock the bands to fix this issue.

Suppose I lock onto a specific tower associated with band 13. Then the router will connect to 66 and 2, giving it the “4g+” status. Then, after some time, two of the bands with drop.

I will try this and update on the results.

if you have issues with getting the zip file installed on your router, use these instructions instead. Much easier to use wget.

It didn’t help. I still drop two out of three bands, doesn’t matter which tower it is. Or if I’m connected to two bands, one always drops and never reconnects.

AT+QMBNCFG=“list”
Look AT the result of this AT instruction

+QMBNCFG: “List”,0,1,1,“CDMAless-Verizon”,0x0A010126,202304251
+QMBNCFG: “List”,1,0,0,“Commercial-TMO”,0x0A01050F,202402061
+QMBNCFG: “List”,2,0,0,“ROW_Generic_3GPP_PTCRB_GCF”,0x0A01FF09,202203161
+QMBNCFG: “List”,3,0,0,“TEF_Spain_Commercial”,0x0A010C00,202302071
+QMBNCFG: “List”,4,0,0,“FirstNet”,0x0A015300,202206171
+QMBNCFG: “List”,5,0,0,“Rogers_Canada”,0x0A014800,202303141
+QMBNCFG: “List”,6,0,0,“Bell_Canada”,0x0A014700,202111051
+QMBNCFG: “List”,7,0,0,“Telus_Jasper_Canada”,0x0A01F900,202304281
+QMBNCFG: “List”,8,0,0,“Telus_Consumer_Canada”,0x0A01FA00,202304281
+QMBNCFG: “List”,9,0,0,“Commercial-Sprint”,0x0A010204,202111051
+QMBNCFG: “List”,10,0,0,“VoLTE-ATT”,0x0A010335,202206171
+QMBNCFG: “List”,11,0,0,“CDMAless_Private-Verizon”,0x0A01FD28,202304271
+QMBNCFG: “List”,12,0,0,“Swiss-Comm”,0x0A010411,202304261
+QMBNCFG: “List”,13,0,0,“Telia_Sweden”,0x0A012400,202111051
+QMBNCFG: “List”,14,0,0,“TIM_Italy_Commercial”,0x0A012B00,202111051
+QMBNCFG: “List”,15,0,0,“France-Commercial-Orange”,0x0A010B21,202401081
+QMBNCFG: “List”,16,0,0,“Commercial-DT-VOLTE”,0x0A011F1F,202212061
+QMBNCFG: “List”,17,0,0,“Germany-VoLTE-Vodafone”,0x0A010449,202401201
+QMBNCFG: “List”,18,0,0,“UK-VoLTE-Vodafone”,0x0A010426,202401201
+QMBNCFG: “List”,19,0,0,“Commercial-EE”,0x0A01220B,202111051
+QMBNCFG: “List”,20,0,0,“Optus_Australia_Commercial”,0x0A014400,202111051
+QMBNCFG: “List”,21,0,0,“Telstra_Australia_Commercial”,0x0A010F00,202311071
+QMBNCFG: “List”,22,0,0,“Commercial-LGU”,0x0A012608,202111051
+QMBNCFG: “List”,23,0,0,“Commercial-KT”,0x0A01280B,202308031
+QMBNCFG: “List”,24,0,0,“Commercial-SKT”,0x0A01270A,202111051
+QMBNCFG: “List”,25,0,0,“Commercial-Reliance”,0x0A011B0C,202210211
+QMBNCFG: “List”,26,0,0,“Commercial-SBM”,0x0A011C0B,202401231
+QMBNCFG: “List”,27,0,0,“Commercial-KDDI”,0x0A010709,202401191
+QMBNCFG: “List”,28,0,0,“Commercial-DCM”,0x0A010D0D,202312201
+QMBNCFG: “List”,29,0,0,“VoLTE-CU”,0x0A011561,202310181
+QMBNCFG: “List”,30,0,0,“VoLTE_OPNMKT_CT”,0x0A0113E0,202312141
+QMBNCFG: “List”,31,0,0,“Volte_OpenMkt-Commercial-CMCC”,0x0A012010,202209221
+QMBNCFG: “List”,32,0,0,“ROW_Commercial”,0x0A010809,202401151

OK

try this

@ywp

This made no change. I'm not trying to connect to 5G anyway, just trying to hold multiple 4G connections so I can have 4G+.

I noticed something relating to the APN. If I use "VZWINTERNET" I drop bands, however with "internet" I don't drop bands but get throttled. Yes, my IMEI is changed and whatever. This is very weird.

VSBLINTERNET
Have you tried this apn?

@ywp

Yes, it fails to connect.

Can you share your device with GoodCloud for remote viewing?
After sharing successfully, please tell me your mac address and password
Make sure your device has another way to access the Internet
Technical Support via GoodCloud.tar (192 KB)