GL-X3000 MetroPCS no 5G NSA/SA

I’ve been searching around and can’t seem to find a resolution that works for Metro By T-Mobile - I’ve got two of these GL-X3000’s latest firmware, latest firmware on the modems. Running ATT and VZW was no issue, but since my VZW coverage is garbage I decided to switch that one to a Metro SIM as its my backup service for when ATT has a coverage gap in our travels.

I’m no stranger to these LTE/5G modules, but most of my experience is running them connected to Linux hosts using NM/MM to manage the connection profiles - My OpenWRT is quite a bit rusty in the 4G/5G context.

What I’ve experienced with Metro -
Band locking to LTE Only - Everything works as expected IPv4 connectivity is good
Band locking to LTE + 5G NSA (What I want) - The modem registers - Pulls IPv6 and IPv4, but no connectivity works on either stack
Band locking to 5G SA (Don’t care too much about SA ATM) - SIM shows unregistered

Putting the SIM back into the “donor phone” 5G connects immediately, both stacks work, etc. I’m also confirmed the APN, etc details as well as the IMEI is correctly registered on the network/my account.

I’ve already tried a few IPv6 modes (Pass-through, Native, etc) and IPv6 never provides connectivity let alone IPv4 over their CGNAT network. I don’t have a 5G module handy to try to run this on a linux node (only an older CAT12 module) - Which works just as well as the modem in the X3000 locked to LTE only bands. I’ve also tried changing the connection profile to generic profiles and this doesn’t change the situation much.

Thanks in advance!

I think I understood about 30% of what you’re talking about. All I can say is when I bought my unit 5G did not work at all. I couldn’t even see the towers. They had to remote into my unit and customize the latest firmware. After they did that for me, the router connects to 5G and has amazing speeds. Apparently there’s issues inside the firmware, and I found a few post about it.

You need to upgrade the firmware on the modem most likely. Not the router. As @joshuaeb09 said, there is a separate process for that.

Firmware (direct download link):