GL-X3000 Multi-Wan Issue

Hi all,

I’m using a GL-X3000 (Spitz AX) for my primary internet at the moment using its Cell modem, which has worked fairly well so far.

However there have been occasional dropouts so I figured I’d use the multi-wan failover and a cheap sim in a spare phone to tether as a backup connection (on a different network ofc).

This… Sort of works, but not really how I thought it would?

As in each connection individually works fine - I can have either only the built in modem enabled or only the tethering enabled and it works fine - But, when I enable both so that they are both connected and it should fail over from the built in modem as necessary, I stop getting DNS service from the router for some reason.

The built in internet status check says both connections are still working and I can even ping IP addresses from devices on the network, but DNS just seems to drop dead. I can even run the Adguard home app and click to test the upstream DNS a second before I plug in the tethering device -works fine.

As soon as the tethering device is plugged in and says its connected, try again and it says it can’t reach upstream DNS.

I’ve tried using different USB cables, different phones, different sim cards in the phones, manually setting encryped/unencryped DNS, using adguard or not, just setting the router to automatic DNS, same issue each time.

Any suggestions? The automatic WAN failover was one of the main reasons I got this router and at the moment I can’t really use it how its intended, so any advice would be helpful.

Firmware version (as shown in Upgrade page):
Current Firmware

Version: 4.0
Firmware Type: 0403release7
Compile Time2023-11-15 14:56:38(UTC+08:00)

If there’s any other info that would be helpful let me know and I’ll provide it happily, really want to get this working.

What order (/weighting) have you set for failover?

Can you take a screenshot of your settings?
Please also export the log.

Got it set to failover so don’t see a ‘weight’ option but this is the priority list - I have the Tethering interface set to the lowest priority although none of the others apart from cellular are connected at all.

Log export here: Most recent event was I connected to tethering for about a minute then disconnected it again to make sure that it was in the log. (25.0 KB)

Thank you very much for your feedback.

This is bug.We will fix this issue as soon as possible.

Thank you, if you need me to test a fix or anything let me know.

I saw the beta firmware for the X3000 4.0-0404release1 mentioned a change to the failover function and upgraded to it to test.

Gotten things set up the way I remember and all looks to be working OK now, issue solved!

Thanks for the update. Glad to hear that.