Gl-X3000 no roaming germany

Hello to the community

I run a Gl-X3000 with the current 4.3.5 beta firmware. As a provider I use German Telekom.

I am currently staying on the German side at Lake of Constance. Unfortunately, the router always logs into the Swiss network even though roaming is switched off under manual settings. I.e. the “roaming off” configuration does not seem to work.

Is there a way to manually assign the desired network to the router?

Thank you for your support!


EDIT: sorry for the double post. It’s the same issue as here: click

I think I have the solution.
I wrote it in following comment

I you have any questions contact me on Instagram: Bene.Filmz

It needs to lock the cell tower, Please refer to this link: Lock Onto That Cell Tower - GL.iNet

We are also integrating this feature into the firmware.


Dear lizh,

when you integrate this feature, could you please make sure, thats it’s possible to see the mmc and mnc to make sure to connect to the correct country and provider?

1 Like

It will disaply mcc and mnc.

To bridge the time until the functions are implemented in the firmware, I would like to set the network to be used manually on the console.

Here I have taken the following steps (thx @Bene !!!):

  • Tool socat installed
  • logged into the modem with “socat – /dev/ttyUSB2,crnl” via console
  • the currently available cells are queried with “AT+QSCAN=3.1”

up to here everything is successful and the available cells are correct listed.

The attempt to access the 4g network with “AT+QNWLOCK=“common/4g”,1,1300,224” is confirmed with “ok” but has no effect whatsoever. The attempt to restart the modem with “AT&F0” is also confirmed with “ok”, but there is no restart. Also a complete restart of the Gi-X3000 have no effect.
An attempt to lock the 5g modem with “AT+QNWLOCK=“common/5g”,431070,716,0,1” is acknowledged with ERROR 907.

Can anyone help me on this matter?


Can you provide screenshots of your queried cell list?
Which provider do you use?
I noticed with o2 that I can not dial into 5g networks because o2 currently only provides 5g nsa, that’s why I disabled the 5g sa bands on manual settings.

Maybe you can try a hard reset and then check if the band locking is successful.

@bene many thanks for you reply!
here the result of my network scan from the last evening (currently I’m out from this location):

type or paste code here
```+QSCAN: "NR5G",262,01,431070,715,-104,-12,22,0,4F2C0E101,8034,106,1,17,2,-
+QSCAN: "LTE",262,01,6400,170,-104,-12,-2,65534,1ECF200,67B7,50,20
+QSCAN: "LTE",262,03,6200,285,-112,-17,13,2,1676601,E923,50,20
+QSCAN: "LTE",228,01,9435,1,-117,-10,11,118,12F2C04,B71,75,28
+QSCAN: "LTE",228,02,9335,159,-119,-16,10,112,1690A60,9D76,25,28
+QSCAN: "LTE",262,03,1600,224,-115,-16,9,3,1676619,E923,75,3
+QSCAN: "LTE",262,02,6300,250,-86,-7,38,27,1255402,BA0E,50,20
+QSCAN: "LTE",262,02,1801,181,-120,-13,6,22,1255409,BA0E,100,3
+QSCAN: "LTE",262,02,100,332,-107,-10,17,23,32E4B14,BA0E,100,1
+QSCAN: "LTE",262,01,1444,387,-108,-11,15,7,1DF5F02,67B7,50,3
+QSCAN: "LTE",262,01,500,350,-109,-7,13,6,1DF6507,67B7,100,1
+QSCAN: "LTE",262,01,3749,487,-98,-7,24,11,1DF5F04,67B7,50,8
+QSCAN: "LTE",262,01,1300,256,-107,-8,15,10,1DF5F00,67B7,100,3
+QSCAN: "LTE",228,02,3598,369,-123,-21,8,108,1694B0C,9D6C,50,8
+QSCAN: "LTE",262,03,9260,319,-135,-23,-10,65531,167D833,C969,50,28

The carrier is German T-Mobile MCC 262 and MNC 01

This parameter is wrong.
This parameter should be:


After executing the above command, you need to run


Finally dialing again

@lizh thanks for your answer. You are absolutely right. It was my mistake when I made the post. But I had tried using the correct syntax.

Now I’ve tried again with 4g. Everything I do has no effect.

What I did:
Scan with:
gl_modem -B 0001:01:00.0 SAT sp ‘AT+QSCAN=3,1’
+QSCAN: “LTE”,262,03,6200,285,-99,-17,25,2,1676601,E923,50,20
+QSCAN: “NR5G”,262,01,431070,715,-98,-13,29,0,4F2C0E101,8034,106,1,17,2,-
+QSCAN: “LTE”,228,03,6400,114,-109,-17,23,112,1C73415,B79F,50,20
+QSCAN: “LTE”,228,02,6400,114,-109,-17,23,112,1C73415,B79F,50,20
+QSCAN: “LTE”,228.02,1850,131,-119,-16.9,113,766402,9D76,100.3
+QSCAN: “LTE”,262,01,3749,487,-87,-11,35,7,1DF5F04,67B7,50,8
+QSCAN: “LTE”,262,01,1300,256,-101,-13,22,5,1DF5F00,67B7,100,3
+QSCAN: “LTE”,228,03,3300,207,-136,-22,-7,106,1C79D1F,B79F,100,7
+QSCAN: “LTE”,228,02,3300,207,-136,-22,-7,106,1C79D1F,B79F,100,7
+QSCAN: “LTE”,262,01,1444,387,-98,-11,24,8,1DF5F02,67B7,50,3
+QSCAN: “LTE”,262.01.3050.247.-134.-20.-11.65535.1973202.67B7.100.7
+QSCAN: “LTE”,262,02,1801,181,-109,-10,17,25,1255409,BA0E,100,3
+QSCAN: “LTE”,262,03,1600,224,-106,-14,18,4,1676619,E923,75,3
+QSCAN: “LTE”,262,02,6300,250,-73,-11,51,23,1255402,BA0E,50,20

Set the parameter with:
gl_modem -B 0001:01:00.0 SAT sp ‘AT+QNWLOCK=“common/4g”,1,1444,387’
Result from the modem: “ok”
root@GL-X3000:~# gl_modem -B 0001:01:00.0 SAT sp ‘AT+CFUN=0’
root@GL-X3000:~# gl_modem -B 0001:01:00.0 SAT sp ‘AT+CFUN=1’
But none of this has any effect. The router always remains in the Swiss network with the ID 228.

I was also in contact with an engineer from TMobile. He said that the router switches every minute between the German and Swiss transponders.

In my opinion, the main flaw is that the “Data roaming ON/OFF” button has no function to only use networks with ID 262.

@GLInet what is your opinion on the subject?

Many thanks for the support


Please exec to check the lock information.


If the above information is correct,Please help to capture data packaget.

@lizh many many thanks for you support!

I have already done what you mean

root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp 'AT+QSCAN=3,1'

+QSCAN: "LTE",262,03,6200,285,-100,-17,24,2,1676601,E923,50,20
+QSCAN: "LTE",228,02,6200,70,-100,-17,-4,0,1691304,9D76,-,20
+QSCAN: "NR5G",262,02,375390,673,-124,-16,4,0,000ED80DE,BBBA,106,3,82,2,-
+QSCAN: "NR5G",262,01,431070,477,-101,-12,25,0,4F2E51800,8034,106,1,17,2,-
+QSCAN: "LTE",228,02,3598,390,-113,-30,15,98,1690A0C,9D76,50,8
+QSCAN: "LTE",262,01,6400,345,-106,-15,16,4,1DF9C02,67B7,50,20
+QSCAN: "LTE",228,03,522,198,-117,-20,14,109,1C75B29,B79F,75,1
+QSCAN: "LTE",228,02,522,198,-117,-20,14,109,1C75B29,B79F,75,1
+QSCAN: "LTE",228,02,1850,66,-121,-23,8,106,765C02,9D76,100,3
+QSCAN: "LTE",228,02,9335,159,-107,-15,21,115,1690A60,9D76,25,28
+QSCAN: "LTE",262,01,1444,387,-99,-11,24,7,1DF5F02,67B7,50,3
+QSCAN: "LTE",228,03,3300,207,-128,-16,1,113,1C79D1F,B79F,100,7
+QSCAN: "LTE",228,02,3300,207,-128,-16,1,113,1C79D1F,B79F,100,7
+QSCAN: "LTE",262,01,1300,256,-101,-13,22,6,1DF5F00,67B7,100,3
+QSCAN: "LTE",228,01,9435,1,-107,-13,21,116,12F2C04,B71,75,28
+QSCAN: "LTE",262,01,3749,487,-86,-7,36,12,1DF5F04,67B7,50,8
+QSCAN: "LTE",262,02,1801,181,-104,-8,22,25,1255409,BA0E,100,3
+QSCAN: "LTE",262,03,1600,224,-107,-13,18,6,1676619,E923,75,3
+QSCAN: "LTE",262,02,6300,250,-73,-8,51,26,1255402,BA0E,50,20

root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp ‘AT+QNWLOCK=“common/4g”,1,1444,387’

root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp 'AT+QNWLOCK="common/4g",1,1444,387'


root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp 'AT+QNWLOCK="common/4g"'

+QNWLOCK: "common/4g",1,1444,387

root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp 'AT+QENG="servingcell"'

+QENG: "servingcell","NOCONN","WCDMA",228,02,5078,1C266AF,2963,107,227,-86,-9,-,-,-,-,-


you see, the “AT+QNWLOCK=“common/4g”,1,1444,387” have no impact.

After that I created a qlog like your link. However, the problem is that the GZ file is more than 28 MB. What option do I have to send you the log.




You can send log to above email.


root@GL-X3000:/usr/bin# gl_modem -B 0001:01:00.0 SAT sp ‘AT+QENG=“servingcell”’

+QENG: “servingcell”,“NOCONN”,“WCDMA”,228,02,5078,1C266AF,2963,107,227,-86,-9,-,-,-,-,-


This tower only supports 3G?

done. I hope the file isn’t with 28MB to large.

I don’t now. But that is the wrong tower.

The frequency 1444 has a tower in Germany with ID 262 (show the list above), but “servingcell” command show a ID228 what is a ID from Swiss. That is what I mean that the QNWLOCK has no impact.

Thank you for your quick support!


Hi saho1:

I have not receive this email yet. Did you send it?


Hi saho1:

I need your help to capture a packet,again.

1,Insert a USB flash disk and use the df command to get the mount path, remember the path:/tmp/mountd/disk1_part1/

2,Use the following command to start qlog:

qlog-ar9531-sha256-75fe8b -f quectel_v15.cfg -s /tmp/mountd/disk1_part1/qlogs_$(date +%Y%m%d%H%M) & (1.6 KB)

3, Execute the following command:

gl_modem -B 0001:01:00.0 SAT sp AT+CFUN=0
gl_modem -B 0001:01:00.0 SAT sp AT+CFUN=1


I have send you a mail with a link to the log.

Many many thanks!


@lizh do you have any news for me?

I also have a GL-x750 v2. There I have the same observation that the tMobile Sim registers in the Swiss network despite deactivated roaming.

We have checked the information. But I’m still not getting vaild information

If it’s all right with you, Can you share this device with ‘gl.inet_support’ through the cloud platform?
Also please help connect network cables to the wan port.

I will debug it check some information.