GL-X3000 Roaming wasn't working with my sim, I did this and it works now

Just in case this helps some one else, I tried everything to get the X3000 to work with my Id Mobile sim while in France and this worked for some reason.

The sim was initially able to register to the roaming network, but only send/receive texts, it would not connect to the internet.

What I did was enter the advanced settings and go to network - interfaces
Next to the modem_0001 it says (and still does): Unsupported protocol type.

so I clicked on the install protocol link and installed all the packages on that page, even the vpn ones, I didn’t know which I needed.

next I cleared the filter and went to the updates tab and updated all the packages that showed up.

Then it worked.

Maybe it was only one package I needed, I don’t really care, it seems to be working well now.

It is interesting.

The packages and protocols you install may not matter.

Maybe the modem just need a little time to register in the roaming network.