GL-X3000 Spitz AX - 15 Mbit/s with 5G

I do not block or limit any bands. I know it’s not Telekom, but with the o2 data sim I’m on 5g NSA and am connected to LTE band 3 and NR5G-NSA band 78.

Eric

I also got an error when I entered this command on my Spitz AX via a copy and paste. I then deleted the <=“List”> portion of the command and entered it manually and that worked.

@EricG Just saw this. You beat me too it.

1 Like

This happens due to differences for the " marks. You typically just need to replace those.

1 Like

+qmbncfg: “List”,0,1,1,“Commercial-DT-VOLTE”,0x0A011F1F,202212061
+qmbncfg: “List”,1,0,0,“TEF_Spain_Commercial”,0x0A010C00,202302071
+qmbncfg: “List”,2,0,0,“FirstNet”,0x0A015300,202206171
+qmbncfg: “List”,3,0,0,“Rogers_Canada”,0x0A014800,202303141
+qmbncfg: “List”,4,0,0,“Bell_Canada”,0x0A014700,202111051
+qmbncfg: “List”,5,0,0,“Telus_Jasper_Canada”,0x0A01F900,202304281
+qmbncfg: “List”,6,0,0,“Telus_Consumer_Canada”,0x0A01FA00,202304281
+qmbncfg: “List”,7,0,0,“Commercial-Sprint”,0x0A010204,202111051
+qmbncfg: “List”,8,0,0,“Commercial-TMO”,0x0A01050F,202303091
+qmbncfg: “List”,9,0,0,“VoLTE-ATT”,0x0A010335,202206171
+qmbncfg: “List”,10,0,0,“CDMAless_Private-Verizon”,0x0A01FD28,202304271
+qmbncfg: “List”,11,0,0,“CDMAless-Verizon”,0x0A010126,202304251
+qmbncfg: “List”,12,0,0,“Swiss-Comm”,0x0A010411,202304261
+qmbncfg: “List”,13,0,0,“Telia_Sweden”,0x0A012400,202111051
+qmbncfg: “List”,14,0,0,“TIM_Italy_Commercial”,0x0A012B00,202111051
+qmbncfg: “List”,15,0,0,“France-Commercial-Orange”,0x0A010B21,202111051
+qmbncfg: “List”,16,0,0,“Germany-VoLTE-Vodafone”,0x0A010449,202111051
+qmbncfg: “List”,17,0,0,“UK-VoLTE-Vodafone”,0x0A010426,202111051
+qmbncfg: “List”,18,0,0,“Commercial-EE”,0x0A01220B,202111051
+qmbncfg: “List”,19,0,0,“Optus_Australia_Commercial”,0x0A014400,202111051
+qmbncfg: “List”,20,0,0,“Telstra_Australia_Commercial”,0x0A010F00,202304251
+qmbncfg: “List”,21,0,0,“Commercial-LGU”,0x0A012608,202111051
+qmbncfg: “List”,22,0,0,“Commercial-KT”,0x0A01280B,202306271
+qmbncfg: “List”,23,0,0,“Commercial-SKT”,0x0A01270A,202111051
+qmbncfg: “List”,24,0,0,“Commercial-Reliance”,0x0A011B0C,202210211
+qmbncfg: “List”,25,0,0,“Commercial-SBM”,0x0A011C0B,202111051
+qmbncfg: “List”,26,0,0,“Commercial-KDDI”,0x0A010709,202306131
+qmbncfg: “List”,27,0,0,“Commercial-DCM”,0x0A010D0D,202301051
+qmbncfg: “List”,28,0,0,“VoLTE-CU”,0x0A011561,202204211
+qmbncfg: “List”,29,0,0,“VoLTE_OPNMKT_CT”,0x0A0113E0,202306071
+qmbncfg: “List”,30,0,0,“Volte_OpenMkt-Commercial-CMCC”,0x0A012010,202209221
+qmbncfg: “List”,31,0,0,“ROW_Commercial”,0x0A010809,202306011

OK

Ok as far as i understood it is normal that my X3000 connect to LTE Band 3 as it needs that to connect to 5G NSA band. so far so good…

so how to make it connect to the 5G NSA Band…

I have sort of the same issue with Verizon in the states. To ensure the 5G NSA connection, I had to band lock the LTE band and the 5G NSA band.
In my case it is LTE 66 and 5G NSA n5.
I did a field test mode on my iPhone to see what bands it was using for LTE & 5G.
Maybe you can do something similar and lock LTE band 3 and whatever band you need for 5G NSA and see how it goes.

in my case i open only the 3 main Band for LTE (3,7,20) and leave all 5g NSA open.
So it can connect LTE and than use all kind of NSA Band. Did you mean like this?

The X3000 connect to the LTE Band but it does not go further and connect to the NSA Band. any way to force that?

Ali,

I wonder if it’s the mbn profile for Telekom that is preventing 5g NSA connection? Maybe try the ROW_Commercial mbn profile (it’s the last one in your list). You might try the following but use the ROW_Commercial mbn profile:

This is from the above link but modified for the ROW_Commercial mbn profile:

(1) It appears that the “autoselect” MBB in the modem picked COMMERCIAL-Tmobile, which would be normally ok. BUT I seemed to remember something about selecting a generic profile in the modem.

I listed the profiles here:

AT+QMBNCFG="list"

And found a “generic looking” profile as: "ROW_Commercial",0xA010809,202306011

(2) Used the following AT command strings.

Turned off auto select and deactivate with

AT+QMBNCFG="AutoSel",0

And then entered:

AT+QMBNCFG="Deactivate"

Then selected the proper “generic” modem

AT+QMBNCFG="Select", "ROW_Commercial"

Checked to be sure the profile is selected:

AT+QMBNCFG="list"

You should see the ROW_Commercial entry at the top of the list now.

Then REBOOT.

MAKE SURE YOU TYPE IN THE AT COMMANDS. DO NOT COPY AND PASTE!!!

If changing to the ROW_Commercial mbn profile does not work, you can switch back to auto select by doing the following command:

AT+QMBNCFG="AutoSel",1
1 Like

10000x Thx man… this totaly helped me out :slight_smile:
I did it exactly like you described from the other post and it worked now :smiley:

I got now something about 240 Mbit/s with the router and 380-420 with my Mobile phone (Xiaomi mi 11 Pro). Only thing that would be interesting to know is why my Phone still has better connection even it has no extra antenna and is very compact.

@Gl inet Team:

  1. TTL is not needed in Germany. By german law it is not allowed for provider to tread Router different than phones
  2. APN Pass and Username is not needed for German Telekom (This is the APN: internet.telekom or internet.v6.telekom)
  3. The Profile that need to be used for Germany if you want 5G connection is “ROW_Commercial”

=> Would be great if we have that new information handled in future firmware. It will for sure reduce the support mails and contacts but also return and refunds :slight_smile:

Also just Purchased a 2nd one!

I’m receive, thank you

I start setup my 2nd X3000 and just did the latest update (4.4.8) and it imidiatly start connecting with 5G NSA (which my old one with old firmware had problems with).
But the Connection is only 90 Mbit/s even it has same Simcard as my other Device with 250 mbit/s.
I also change the Profile to “ROW_Commercial”

The only difference is the modemfirmware.

@gl.inet Team: Is it possible to integrate modemfirmware into normal Firmware upgrade? It is very hard for me and i strugle hard to do the SSH update (even i consider myself mid-range user) :slight_smile:
It will enhance the customer satisfaction if possible

1 Like

Thank you, Thank you!
I've had same issue for several days, I almost gave up and was going to put up with 5-15Mbits. You've solved this for me. Note I'm based in Croatia, Umag to be precise, and have a SIM from
Hrvatski Telekom with unlimited internet. I've book marked this page.

Seriously can't tell you how grateful I am! :grinning:

John

1 Like