GL-X3000 Spitz AX - 15 Mbit/s with 5G

I purchased a GL-X3000 Spitz AX and inserted a German Telekom Simcard with unlimited internet and no limit to router. I have full 5G connection on my Phone but on the GL-X3000 it show 4G+.
On my Phone (Xiaomi 11 Pro) i have about 420 Mbit/s but with the Gl-X3000 i got only 15 Mbit/s.

I tried TTL 64 - 65 - 66. I have good connection as my Phone achive same speed next to it.

Any ideas what might be wrong?

My guess is you need to update the modem firmware.
Directions here.
Various firmware releases here
I am in the US. Running the file dated 02/01/24 right now. This got me to connecting to 5G on Verizon with stability. These routers seem to be shipping with very old modem firmware.

Hi, i just downloaded latest firmware few minutes before you reply. I took this one it still show 4.0 in the menu but i guess i have now 4.4.6

Not router firmware. Cellular modem firmware.

i am about 100% sure i would brak the deivce when i handle from my side… Is there no official Gl-Inet solution? I mean the device is very new it should support 5g without customer deepdive into the system.

Firmware upgrades need to be applied periodically as telecom providers make changes to their networks. It may not be common, but there are 5g changes in later firmwares that are available since production of the X3000. This could help your performance, and the guide linked has very good step by step instructions you can copy and paste. The only real difference would be if you use a different firmware than the instructions reference.

The need to update the modem firmware will be a thing with just about any manufacturer.
5G (contrary to what the telecoms want you to believe) is still fairly new. The link above is GL.inet’s official how to.
Your could also reachout to support. There is a way to share your router over GoodCloud with them and they could likely help out with the upgrade.

I was in Berlin a couple weeks ago with my Spitz AX using an unlimited o2 data sim (German version). Download speeds were anywhere from 30mbps to 450mps. I did upgrade the MODEM firmware to RM520NGLAAR03A02M4GA.


just did the update with the support of gl inet team over good cloud. I still have only 15-20 Mbit/s…

Any other ideas or anything i can provide to clear things up?

Hard for me to troubleshoot as I am not in Germany. :grinning:
Some other guesses…
Your router seems to only be getting LTE.
Is the SIM card good for 5G?
With Verizon here in the states at my home, the LTE tower is closer and gives a stronger signal.
I have found I have to use the band locking feature to force it to 5G.
Interestingly, that 5G tower must be more congested as at peak times, the LTE tower gives better speed.
The more I use the cellular router and research online, it seems the technology behind the scenes is not as robust as modern cellphones.
What I mean by that, is some manual intervention with band locking or tower locking may be needed to get the top speeds. The tower with the strongest signal may not always produce the fastest data speeds.


What happens if you clear the Authentication, Username and Password fields? Do you still get a connection? It looks like you’re only getting an LTE connection?

Which mbn profile is your connection using? If you run the command AT+QMBNCFG=“List” the first entry should show which mbn file is being used for the connection.


Can you confirm that the cellular plan has not only unlimited internet (I’m assuming this means data) but also does NOT have any throttling for hotspot/tethering usage.

The TTL mod is only necessary to hide tethering and avoid any throttling that may be imposed. Note that some of the US carriers have figured out other ways to detect tethering and thus the TTL mod no longer works.


Germany is pretty flexible with using sim cards in other devices (unlike the US). When I travel to Germany, I’ve used pay as you go lines in an ipad and a cellular router without issues.

Ali should try just setting the apn and leave the remaining fields blank to see how the router connects.


5g Router is very common in germany and i dont thing that anyone expect normal user to handle tower lock inside the routerinterface to achive 5g :slight_smile:

however in my case:

  • Simcard is 5G combatible. I used same card also in my phone
  • The next 5g Antenna is about 100 Meter (328 ft) away
  • There is no limit from my contract in speed or valuem
  • By the latest german law it is forbidden for carrier to make any difference between cellphone and router. So the provider can not treat reouter different in speed or volume

=> What i did test was to block all LTE bands and achived 25 but still very low compared to my phown with 420

I wonder if you need to clone your phone IMEI number to the X3000. Just guessing here, but it sounds like this may not be needed based on your message.

========Regarding Authenfication / Username / Password =========
German Telekom has only 3 Values that they have in there configuration on there website.
APN: internet.telekom or internet.v6.telekom or internet.home
USER: telekom
PASS: tm

=> internet.v6.telekom you can if you activate IPv6. I tried with IPv6 and this APN but in my case was not working.

=> internet.home is the APN that German Telekom setup in there own 5g Router. I also tried but same speed.

================= regarding the login ===============
i use PAP (suggested by Provider) but i tried without and it still works

================= regarding list commant ===============
i am not sure if i did it correctly. I get an error. Please check

actually in germany it is forbidden by law to treat router different than mobile phones. So provider dont do that (also confirmed that by hotline and by email) however in my case:

  • Simcard is 5G combatible. I used same card also in my phone
  • There is no limit from my contract in speed or volume

To test i downloaded with my phone 3 gig with 420 Mbit/s

I just read some articles about how Germany 5G network works (5g NSA).

As Germany uses Inter-Site Anchoring is it possible that the GL X3000 just connect to the LTE and dont hoockup to the 5g network? anyone familar with this topic?

looks like there are many Problems with Gl X3000 in germany :frowning: just found several older articles.
GL-X3000 Telekom Germany - #19 by SpitzAX3000

My Mobile Phone (Xiaomi Mi 11 Pro) uses Band 3 and Band 20 (NSA). So i tried to open only this two Band in my X-3000 but than it does not connect at all.

============Band Block / open ================
When i allow all 5G NSA Band but nothing else than it also does not connect.

looks like it only connect to LTE Band

5G NSA needs to be registered through LTE first, so you need to select the LTE band as well

1 Like


I just logged in to my Spitz AX that is in Berlin (through goodcloud). I’m using a German o2 data sim. Here’s the list I see when I run the command at+qmbncfg=“list”:

+QMBNCFG: “List”,0,1,1,“TEF_Spain_Commercial”,0xA010C00,202302071
+QMBNCFG: “List”,1,0,0,“VoLTE-ATT”,0xA010335,202206171
+QMBNCFG: “List”,2,0,0,“FirstNet”,0xA015300,202206171
+QMBNCFG: “List”,3,0,0,“Rogers_Canada”,0xA014800,202303141
+QMBNCFG: “List”,4,0,0,“Bell_Canada”,0xA014700,202111051
+QMBNCFG: “List”,5,0,0,“Telus_Jasper_Canada”,0xA01F900,202304281
+QMBNCFG: “List”,6,0,0,“Telus_Consumer_Canada”,0xA01FA00,202304281
+QMBNCFG: “List”,7,0,0,“Commercial-Sprint”,0xA010204,202111051
+QMBNCFG: “List”,8,0,0,“Commercial-TMO”,0xA01050F,202303091
+QMBNCFG: “List”,9,0,0,“CDMAless_Private-Verizon”,0xA01FD28,202304271
+QMBNCFG: “List”,10,0,0,“CDMAless-Verizon”,0xA010126,202304251
+QMBNCFG: “List”,11,0,0,“Swiss-Comm”,0xA010411,202304261
+QMBNCFG: “List”,12,0,0,“Telia_Sweden”,0xA012400,202111051
+QMBNCFG: “List”,13,0,0,“TIM_Italy_Commercial”,0xA012B00,202111051
+QMBNCFG: “List”,14,0,0,“France-Commercial-Orange”,0xA010B21,202111051
+QMBNCFG: “List”,15,0,0,“Commercial-DT-VOLTE”,0xA011F1F,202212061
+QMBNCFG: “List”,16,0,0,“Germany-VoLTE-Vodafone”,0xA010449,202111051
+QMBNCFG: “List”,17,0,0,“UK-VoLTE-Vodafone”,0xA010426,202111051
+QMBNCFG: “List”,18,0,0,“Commercial-EE”,0xA01220B,202111051
+QMBNCFG: “List”,19,0,0,“Optus_Australia_Commercial”,0xA014400,202111051
+QMBNCFG: “List”,20,0,0,“Telstra_Australia_Commercial”,0xA010F00,202308291
+QMBNCFG: “List”,21,0,0,“Commercial-LGU”,0xA012608,202111051
+QMBNCFG: “List”,22,0,0,“Commercial-KT”,0xA01280B,202308031
+QMBNCFG: “List”,23,0,0,“Commercial-SKT”,0xA01270A,202111051
+QMBNCFG: “List”,24,0,0,“Commercial-Reliance”,0xA011B0C,202210211
+QMBNCFG: “List”,25,0,0,“Commercial-SBM”,0xA011C0B,202111051
+QMBNCFG: “List”,26,0,0,“Commercial-KDDI”,0xA010709,202306131
+QMBNCFG: “List”,27,0,0,“Commercial-DCM”,0xA010D0D,202301051
+QMBNCFG: “List”,28,0,0,“VoLTE-CU”,0xA011561,202204211
+QMBNCFG: “List”,29,0,0,“VoLTE_OPNMKT_CT”,0xA0113E0,202306071
+QMBNCFG: “List”,30,0,0,“Volte_OpenMkt-Commercial-CMCC”,0xA012010,202209221
+QMBNCFG: “List”,31,0,0,“ROW_Commercial”,0xA010809,202306011


It looks like my o2 sim is using the TEF Spain profile? I’m curious which profile Telekom connects to.

Try typing the command at+qmbncfg=“list” in the GUI. If you cut and paste it in to the box, sometimes the quotes aren’t right and you get an error message.