GL-X3000 Spitz AX LTE with GoodCloud

Using the Spitz with a SIM card for LTE Internet access so trying to use GoodCloud to remotely manage the device however it appears after reboot and LTE Public IP update i’m no longer able to connect with the Spitz via GoodCloud. I would assume it’s expected to auto update the Public IP when it changes. Any insights? I’ve tried to reboot, bind/unbind etc. but same results.

Please post the log files so we can check what is going on. The cloud log is enough.

See logs below after re-installing cloud packages which did not help: (Masking MaC/SN/ID)

Sun Jan 14 11:41:48 2024 daemon.err eco: (/usr/bin/gl-cloud:396) reconnect mqtt in 5s…
Sun Jan 14 11:41:53 2024 daemon.debug eco: (/usr/bin/gl-cloud:186) fetch server:
Sun Jan 14 11:41:54 2024 daemon.err eco: (/usr/bin/gl-cloud:211) fetch server fail:-5 tls device info invalid
Sun Jan 14 11:41:54 2024 daemon.err eco: (/usr/bin/gl-cloud:396) reconnect mqtt in 5s…

After reinstalling (and reseting the configs) you need to reset the authorisation in Goodcloud. Either by deleting the device there, unbinding and binding or by using the option „Re-activate“

I am confused about the TLS error you got there in the logs. Are you sure the router is able to reach the website? Maybe there is currently an issue like a „Contract exceeded“ warning message instead of the website?

Ya i’ve tried all of this already, no other error messages that i can see.
This happened after LTE public IP updated.

Do you use AdGuard or any other DNS server?

No those services are disabled.
As i mentioned all was working until Router rebooted and received new LTE public IP.
Now device shows offline with old Public IP still registered.

But the router itself works fine and you can connect to the internet? Only Goodcloud is broken right now?

Yes that is correct.

Could you SSH into the router and execute:

curl -v
  • TLSv1.3 (OUT), TLS handshake, Client hello (1):
  • TLSv1.3 (IN), TLS handshake, Server hello (2):
  • TLSv1.2 (IN), TLS handshake, Certificate (11):
  • TLSv1.2 (IN), TLS handshake, Server key exchange (12):
  • TLSv1.2 (IN), TLS handshake, Server finished (14):
  • TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
  • TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (OUT), TLS handshake, Finished (20):
  • TLSv1.2 (IN), TLS handshake, Finished (20):

GET /getCaCert/ca.crt HTTP/1.1
User-Agent: curl/7.83.1
Accept: /

< HTTP/1.1 200 OK
< Server: nginx/1.16.1
< Date: Mon, 15 Jan 2024 14:31:34 GMT
< Content-Type: application/x-x509-ca-cert
< Content-Length: 1285
< Last-Modified: Thu, 30 Mar 2023 07:46:59 GMT
< Connection: keep-alive
< ETag: “64253e73-505”
< Accept-Ranges: bytes

looks good so far. Next step would be that team member of GL will have a look.

@hansome Maybe you or someone else?

1 Like

Thanks any further insights on what could be causing this issue?

can you provider your device’s mac?

1 Like

MAC sent via PM let me know.

@portugal1982 Looks like your GL-X3000 is still disconnected with GoodCloud, if you need any help, please feel free to contact us.