GL-X3000 Spitz Ax - No Wifi's listed in repeeater mode

So bought an X3000 to replace the MT1300 we were using in France for a cabin, because the signal isn’t great from the site wifi and wanted something better to pick it up (thinking the X3000 could have an external antenna added in the future too). Also I wanted the MT1300 back for my normal travel.

Tested it in the UK repeating my home Wifi, and worked great all the way down the road. Brought it to France and now it will find no Wifi network when clicking on “connect” on the repeater option.

Going into the Luci dashboard it can find all the networks it just wont find anything in the GUI. Great I thought, just connected through Luci, but everytime I try it says “applying changes” but then errors out and says reverting changes.

Pulling my hair out on this one, actually remeber having a similar problem with the MT1300, and it was a firmware issue think, its currently running 4.1.0 beta 3, but I remeber spending hours figuring it out and now in the same situation! AHHH

The X3000 is currently , 4.0-release20300 I had just downgraded to this from the latest (4.0-0405release1) but still no luck.

Due to leave in 2 days so any quick responses / suggestions would be greatly appreciated!

The problem with Wi-Fi is that there are country codes and devices with some codes cannot see / connect to Wi-Fi with “wrong” country code. The X3000 does not allow to change the country code, so this might be the issue here.

Could you please post the logs after you tried to connect using luci?

please try to “Allow repeating of DFS channels”.

image

Yeah enabled the repeating of DFS channels doesn’t seem to work either.

Its weird because it doesn’t find any Wifi networks in the main GUI, even my phone hotspot which I also tested with in the UK

Here’s the log of trying to connect in the Luci interface to my mobile phone hotspot.

Sun Jan 14 08:46:04 2024 daemon.err eco: (gl-cloud:176) fetch ca fail: connect fail: resolve “gslb-eu.goodcloud.xyz” fail: 0 address
Sun Jan 14 08:46:04 2024 daemon.err eco: (gl-cloud:510) reconnect mqtt in 5s…
Sun Jan 14 08:46:09 2024 daemon.err eco: (gl-cloud:176) fetch ca fail: connect fail: resolve “gslb-eu.goodcloud.xyz” fail: 0 address
Sun Jan 14 08:46:09 2024 daemon.err eco: (gl-cloud:510) reconnect mqtt in 5s…
Sun Jan 14 08:46:14 2024 daemon.err eco: (gl-cloud:176) fetch ca fail: connect fail: resolve “gslb-eu.goodcloud.xyz” fail: 0 address
Sun Jan 14 08:46:14 2024 daemon.err eco: (gl-cloud:510) reconnect mqtt in 5s…
Sun Jan 14 08:46:15 2024 kern.notice kernel: [55128.947612] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(2), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1023]2c:db:07:ef:6b:fe
Sun Jan 14 08:46:15 2024 kern.debug kernel: [55128.960522] entrytb_aid_aquire(): found non-occupied aid:4, allocated from:4
Sun Jan 14 08:46:15 2024 kern.warn kernel: [55128.967582] 7981@C13L2,MacTableInsertEntry() 1537: New Sta:2c:db:07:ef:6b:fe
Sun Jan 14 08:46:15 2024 kern.notice kernel: [55128.976268] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647: Recv Assoc from STA - 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:15 2024 kern.err kernel: [55128.985447] WiFi@C15L1,WPAValidateRSNIE() 3167: [ERROR] : invalid PMKID !!!
Sun Jan 14 08:46:15 2024 kern.err kernel: [55128.992494] 7981@C08L1,APBuildAssociation() 693: invalid status code(1) !!!
Sun Jan 14 08:46:15 2024 kern.notice kernel: [55128.999457] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=1)…
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.020980] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(2), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.034834] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647: Recv Assoc from STA - 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.044016] WiFi@C15L1,WPAValidateRSNIE() 3167: [ERROR] : invalid PMKID !!!
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.051025] 7981@C08L1,APBuildAssociation() 693: invalid status code(1) !!!
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.057987] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=1)…
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.098944] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(2), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.112826] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647: Recv Assoc from STA - 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.121985] WiFi@C15L1,WPAValidateRSNIE() 3167: [ERROR] : invalid PMKID !!!
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.129008] 7981@C08L1,APBuildAssociation() 693: invalid status code(1) !!!
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.135970] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=1)…
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.175700] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(2), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.189570] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647: Recv Assoc from STA - 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.198728] WiFi@C15L1,WPAValidateRSNIE() 3167: [ERROR] : invalid PMKID !!!
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.205738] 7981@C08L1,APBuildAssociation() 693: invalid status code(1) !!!
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.212709] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=1)…
Sun Jan 14 08:46:16 2024 kern.err kernel: [55129.262472] 7981@C08L1,ap_peer_auth_req_at_idle_action() 692: wcid1 exist in Band1 but Recv Band0, CH9 => SKIP
Sun Jan 14 08:46:16 2024 kern.warn kernel: [55129.272490] 7981@C01L2,wifi_sys_disconn_act() 1002: wdev_idx=2
Sun Jan 14 08:46:16 2024 kern.warn kernel: [55129.278659] 7981@C13L2,MacTableDeleteEntry() 1793: Del Sta:2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.285927] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(0), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.debug kernel: [55129.298566] entrytb_aid_aquire(): found non-occupied aid:4, allocated from:4
Sun Jan 14 08:46:16 2024 kern.warn kernel: [55129.305622] 7981@C13L2,MacTableInsertEntry() 1537: New Sta:2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.321080] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647: Recv Assoc from STA - 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.330486] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=0)…
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.339679] 7981@C01L3,wifi_sys_conn_act() 1115: wdev idx = 0
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.345810] 7981@C08L3,hw_ctrl_flow_v2_connt_act() 215: wdev_idx=0
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.469397] 7981@C15L3,WPABuildPairMsg1() 5280: <=== send Msg1 of 4-way
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.480714] 7981@C15L3,PeerPairMsg2Action() 6202: ===>Receive msg 2
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.487548] 7981@C15L3,WPABuildPairMsg3() 5557: <=== send Msg3 of 4-way
Sun Jan 14 08:46:16 2024 kern.notice kernel: [55129.494219] 7981@C15L3,PeerPairMsg4Action() 6632: ===>Receive msg 4
Sun Jan 14 08:46:16 2024 daemon.info dnsmasq-dhcp[5766]: DHCPREQUEST(br-lan) 192.168.8.142 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 daemon.info dnsmasq-dhcp[5766]: DHCPACK(br-lan) 192.168.8.142 2c:db:07:ef:6b:fe RazerBook
Sun Jan 14 08:46:16 2024 kern.warn kernel: [55129.505748] 7981@C15L2,PeerPairMsg4Action() 6994: AP SETKEYS DONE(ra0) - AKMMap=WPA2PSK, PairwiseCipher=AES, GroupCipher=AES, wcid=1 from 2c:db:07:ef:6b:fe
Sun Jan 14 08:46:16 2024 kern.warn kernel: [55129.505748]

Similar issue that someone experienced for the MT3000, but not sure what version of firmware I would have to revert back to, if that indeed is the solution as the downloads page only goes back to 4.0 release 20300

Dunno what the version 8 is?

Could you post a screen from the wi-fi selection in luci?

Hey Admon, here are those screenshots. Purple network is the one I want to ultimately Join (identifies location hence blocking it out), and highlighted in Red in my phone hotspot wifi.

Also Tried changing the country in the configuration - /etc/config/wireless, to FR as in France, as it was set to DE previously

Screenshot_2

Well now I’m pissed, so I tried downloading the oldest firmware I could - Version: 8.0-0009release1 from the downloads page - GL.iNet download center

Didn’t work but then I thought how about changing the Wifi in the repeater settings from “Auto” to 2.4Ghz and force 20Mhz bands, hey presto I got networks listed. Great I thought maybe it was just I wasn’t doing the 2.4 selection on the other firmware, I’ll upgrade test it out and whats the worst that can happen I can downgrade again.

Didn’t work on the latest or the Version: 4.0-release20300 … so tried going back to the v8 release … now it doesn’t work. WTF!

Honeslty for what I’ve paid for this device seriously disappointed with this crap. When the software works its great, but this is the second time (first was with the MT1300) that I’ve spent hours diagnosing and trying to find out the issue!

1 Like

Don‘t worry, it’s not you doing something wrong.
The X3000 (and XE3000 as well) do have one big issue: The Wi-Fi config will be loaded partly from some hidden partition. Due to legal things, I guess.

You can’t change the country code for example. It will simply ignore settings you set. Of course not for all settings, but for some.