GL-X3000 Starlink WAN Speed Negotiation

I have a Spitz connected to Gen 2 Starlink Dishy with a dual midspan POE Injector powered with 12 volts.

I cut the Starlink cable and added regular shielded RJ45 connectors using the T-568B layout. This allows me to easily switch between the Spitz and the OEM router. When Starlink detects a 100Mbps connection downstream of the dish, it reports it on its account dashboard.

The OEM router is working fine with download speeds over 150Mbps. When I connect the Spitz the speeds fall to just below 100 Mbps. Ethtool shows the Spitz (GL-X3000) is negotiating eth0 to 100 Mbps.

Is there a way to manually set the interface to 1000 Mbps? I tried ethtool -s eth0 speed 1000, but it does not accept the command.

1 Like

The wan port of the X3000 is a 2.5G wan port, and the MTK driver does not allow you to change the negotiated rate, so it is the same as your peer end

If you must change, you can take the following steps

  1. Change the 2.5G wan port to a lan on the web page
  2. Change lan to wan on the web page
  3. ethtool -s eth1 autoneg off
  4. ethtool -s eth1 speed 1000
  5. ethtool eth1
1 Like

Thank you for your suggestion. I will swap the wan and lan ports and report back.


Look out:
Step two uses this

1 Like

Update: I could not get the X3000 to work after reversing the WAN and LAN ports. It simply would not negotiate a connection with the Starlink Dishy. After I reverted the ports to their original designations, Dishy connected again to the 2.5G WAN port at 100 Mbps. I don't think it's the cable, as I have tried several different Cat6-certified cables, and I get full-speed connections to the original Starlink Router. For various reasons, I would prefer to use the X3000. It consumes less power and adds 5G/LTE failover.

How did you reverse it?

When reversed, a 2.5Gwan interface is a lan interface
The former lan interface serves as the wan interface
Your Internet connection also needs to be replaced

image
Can I take a look at your ethernet1, ethernet2 interface
The interface after reversal

I have some suspicion that it is a problem with the POE injector, please share the POE injector model name, we can check if it supports 1000Mbps.

Can you connect the Starlink router to this POE injector to check the download speed, or test with another available router? We want to confirm if the POE injector works fine with other router.

2 Likes

Hi Tim,

Thanks for your suggestion. The PoE injector is the Dualie made by Boondocker.io. I wrote to them earlier, and they confirmed that it supports GbE connections with Starlink. Of course, it still could be malfunctioning as both data and power are shared over four wires. These injectors introduce power by using a transformer. I also tried a different injector made by Yaosheng (耀晟 | YAOSHENG - 120W Step Up PoE Injector with comprehensive protection - YSNEAPL12001A), and the connection was similarly limited to 100 Mbps. Based on your suggestion, I will explore some options to strip out the power from the Starlink router cable and pass the signal through the third-party POE injector to the Dishy terminal to test it. I will also retest with a Ubiquiti Express next week. In the meantime, here are the screenshots of what happened when I switched the LAN and WAN ports. The link was up at 100mbps, but It appears that DHCP is not running on eth1. I also attempted to manually assign an IP to that interface but I don't think Starlink works like that.

I appreciate you and your team weighing in with suggestions and advice on this thread.





hello Mohit
Can Ethernet2 Obtain an ip address if the negotiation rate is not changed to 1000?

No, when eth2 is converted to be a WAN port it is not able to get an IP address with the default settings even before using ethtool to set its speed to 1000.

hello
Could you send me the log for a look?
The ip address cannot be obtained
thank you

Thanks, Tim and GL.iNet Staff. In response to your suggestion, I contacted the folks who make the Dual midspan injector, and they sent me a replacement board. It turns out that was the bottleneck. Everything is negotiating correctly, and I am back in business.

I appreciate your support while I eliminated the various failure points to figure out a solution.

Thanks a lot for your update. The vendor replaced the injector with a new model or the same model just a new board?

Same model. They just sent me a new circuit board. It's called the Dualie and is made by Boondocker.io. The product itself is thoughtfully designed and very well-built. I picked it because it allows me to power the GL-X3000 and Dishy with a single 12 VDC power source. It also has wiring for a set of low-current automotive-style switches that allow me to turn the GL-X3000 and Dishy on and off independently of each other. So when I am on 5G/LTE I can send power to the Spitz AX and avoid the 40Watt draw of the Dishy. Thanks again for helping me realize the full potential of this solution.

Thanks for your feedback. “a set of low-current automotive-style switches that allow me to turn the GL-X3000 and Dishy on and off independently”, could you share this device picture and linkage?

In another post, one customer asks if any solution to power on or off GL-X3000 periodically.