GL-X3000 Telekom Germany NR5G-SA Bands Show 'SIM Card Not Registered' Error, NSA Works Fine

Hi everyone,

I'm experiencing an issue with Telekom NR5G-SA bands n1 and n28.

When I attempt to lock onto band n1 (4F328B101), the router displays the error "SIM card not registered." The same error occurs for band n28 (4F3104701).

However, NSA works fine. I tried band masking (selected all NSA & LTE bands) and I successfully get 5G NSA.

device:

  • Modem: GL-X3000 Spitz AX
  • Modem version: RM520NGLAAR03A03M4G
  • Version: 4.0
  • Firmware version: 0409release1

gl_modem -B 0001:01:00.0 SAT sp "AT+QSCAN=3,1"

+QSCAN: "NR5G",262,01,431070,421,-87,-11,39,0,4F328B101,802A,106,1,17,2,-
+QSCAN: "NR5G",262,01,154570,478,-93,-11,33,0,4F3104701,802A,52,28,15,2,-
+QSCAN: "NR5G",262,02,156510,121,-117,-21,1,0,0005A40D4,B9AA,52,28,13,6,-
+QSCAN: "LTE",262,03,1600,242,-,-,-,0,17C3019,C954,-,3

AT+QMBNCFG="list"

+QMBNCFG: "List",0,1,1,"ROW_Commercial",0x0A010809,202401151
+QMBNCFG: "List",1,0,0,"TEF_Spain_Commercial",0x0A010C00,202302071
+QMBNCFG: "List",2,0,0,"ROW_Generic_3GPP_PTCRB_GCF",0x0A01FF09,202203161
+QMBNCFG: "List",3,0,0,"FirstNet",0x0A015300,202206171
+QMBNCFG: "List",4,0,0,"Rogers_Canada",0x0A014800,202303141
+QMBNCFG: "List",5,0,0,"Bell_Canada",0x0A014700,202111051
+QMBNCFG: "List",6,0,0,"Telus_Jasper_Canada",0x0A01F900,202304281
+QMBNCFG: "List",7,0,0,"Telus_Consumer_Canada",0x0A01FA00,202304281
+QMBNCFG: "List",8,0,0,"Commercial-Sprint",0x0A010204,202111051
+QMBNCFG: "List",9,0,0,"Commercial-TMO",0x0A01050F,202402061
+QMBNCFG: "List",10,0,0,"VoLTE-ATT",0x0A010335,202206171
+QMBNCFG: "List",11,0,0,"CDMAless_Private-Verizon",0x0A01FD28,202304271
+QMBNCFG: "List",12,0,0,"CDMAless-Verizon",0x0A010126,202304251
+QMBNCFG: "List",13,0,0,"Swiss-Comm",0x0A010411,202304261
+QMBNCFG: "List",14,0,0,"Telia_Sweden",0x0A012400,202111051
+QMBNCFG: "List",15,0,0,"TIM_Italy_Commercial",0x0A012B00,202111051
+QMBNCFG: "List",16,0,0,"France-Commercial-Orange",0x0A010B21,202401081
+QMBNCFG: "List",17,0,0,"Commercial-DT-VOLTE",0x0A011F1F,202212061
+QMBNCFG: "List",18,0,0,"Germany-VoLTE-Vodafone",0x0A010449,202401201
+QMBNCFG: "List",19,0,0,"UK-VoLTE-Vodafone",0x0A010426,202401201
+QMBNCFG: "List",20,0,0,"Commercial-EE",0x0A01220B,202111051
+QMBNCFG: "List",21,0,0,"Optus_Australia_Commercial",0x0A014400,202111051
+QMBNCFG: "List",22,0,0,"Telstra_Australia_Commercial",0x0A010F00,202311071
+QMBNCFG: "List",23,0,0,"Commercial-LGU",0x0A012608,202111051
+QMBNCFG: "List",24,0,0,"Commercial-KT",0x0A01280B,202308031
+QMBNCFG: "List",25,0,0,"Commercial-SKT",0x0A01270A,202111051
+QMBNCFG: "List",26,0,0,"Commercial-Reliance",0x0A011B0C,202210211
+QMBNCFG: "List",27,0,0,"Commercial-SBM",0x0A011C0B,202401231
+QMBNCFG: "List",28,0,0,"Commercial-KDDI",0x0A010709,202401191
+QMBNCFG: "List",29,0,0,"Commercial-DCM",0x0A010D0D,202312201
+QMBNCFG: "List",30,0,0,"VoLTE-CU",0x0A011561,202310181
+QMBNCFG: "List",31,0,0,"VoLTE_OPNMKT_CT",0x0A0113E0,202312141
+QMBNCFG: "List",32,0,0,"Volte_OpenMkt-Commercial-CMCC",0x0A012010,202209221

I would be very thankful if anyone could help

I recall there is another post in the forum for SA bands in Germany stating that they don’t work.

coud you please provide the link to it?

You will find in the discussion Something related to SA bands in Germany.

i even tried upgrading to beta version RM520NGLAAR03A03M4G_BETA_20240521C, no luck :confused:

:smiling_face_with_tear: i might give up on this, can't find a solution

Maybe SA just does not work on your SIM.

No, it is supporting SA

if anyone could help me fix this issue, i would pay.