GL-X3000 Telekom Germany

I have the same router and it is very fast.

First of all, upgrade your route to latest stable release. If you don’t have custom configuration, wipe the configurations as well during the upgrade.

Once the modem is flashed with the latest firmware, make sure the SIM is fitted correctly and click Auto Setup and wait till it connects to your 5G tower. To verify that you are connected to 5G, it should give you something g similar to this:

Note: when you click Auto Setup the modem will use the 5G band and other preferences saved on the SIM to make the best decision an connect to the 5G tower with strong signal. In rare cases however you The modem connects to a not so fast 5G band. If that happens to you then you need to learn few AT commands to utilize the fastest band.

Thanks for the fast answer,

I have the latest firmware 12.05 .
I tried it with auto setup.
But anyhow it’s not looking like yours.

What is your APN setup?
(In my IPhone it’s “internet.v6.telekom”)
But in the spitzt this causes an error.

Do you know which AT commands are needed?

This is with LTE and APN internet.telekom

This is with IPhone directly

And this is with auto setup and 5G

Hi H_D:

Can you check the band your phone is using?


See attached pic

Then as I said before, go to the manual setup and enable band filter and choose the band that your iPhone was connecting to to get the desired speed.

Yeah I did, and it seems to work.
But it’s a caravan, I think at different places I’ll have different bands …

You can try different bands to get the highest possible speed.

You are right - usually the modem prioritizes the strongest signal to connect to, but strongest signal may not be the fastest band !

but is there any option to have 1th priority to 5G then LTE?

I think this is automatically happen when there is no 5G coverage the modem connects to LTE - exactly like smartphone !

Here are few AT commands that can show you what’s the LTE policy set by your mobile operator on the SIM:


+QCAINFO: “PCC”,1650,100,“LTE BAND 3”,1,265,-73,-15,-37,-4
+QCAINFO: “SCC”,6350,100,“LTE BAND 20”,2,264,-59,-10,-28,9,0,-,-
+QCAINFO: “SCC”,528990,11,“NR5G BAND 41”,916


+QNWINFO: “FDD LTE”,“42004”,“LTE BAND 3”,1650
+QNWINFO: “TDD NR5G”,“42004”,“NR5G BAND 41”,528990


+QNWPREFCFG: “gw_band”,1:2:4:5:6:8:19
+QNWPREFCFG: “lte_band”,1:2:3:4:5:7:8:12:13:14:17:18:19:20:25:26:28:29:30:32:34:38:39:40:41:42:43:46:48:66:71
+QNWPREFCFG: “nsa_nr5g_band”,1:2:3:5:7:8:12:13:14:18:20:25:26:28:29:30:38:40:41:48:66:70:71:75:76:77:78:79
+QNWPREFCFG: “nr5g_band”,1:2:3:5:7:8:12:13:14:18:20:25:26:28:29:30:38:40:41:48:66:70:71:75:76:77:78:79



The above commands can be executed form:

the Internet → Modem Management → AT Command

you can set your preference to LTE then 5G and vice versa: using such commands:

AT+QNWPREFCFG= "mode_pref"

Please refer to the the full manual to know how to set it:


Thanks for this help :grinning:

I have the exact same problem, also Telekom Germany.

On my iPhone I get ~1300 Mbit/s download, on my GL-X3000 ~20 Mbit/s. Both are connected to the same tower and using the same bands. (LTE FDD Band 3, NR5G-NSA Band 78) Also tried via ethernet, so not a WiFi issue.

I got my router a week ago, in the beginning I got the same speeds as on mobile, but a few days ago it suddenly changed.

Anyone has an Idea what I could try?

Any help would be much appreciated!

Do you have any traffic restrictions within your mobile contract?

No, Telekom unlimited. If I put that SIM into my iPhone I get the mentioned speeds.

Unfortunately (for me) this doesn’t seem to be a problem with the GL-X3000. Today I bought a ZTE 5G CPE MC888 and inserted the SIM card into it, same problem.

I have also done a factory reset on the GL with no success. Does anyone have any idea how the speeds can be so different when using a 5G router vs a phone? This is reproducible every time, perfect speed in phones, poor speed in 5G routers. I even set the IMEI of an iPhone I had lying around to no avail :frowning:

Edit: Got an unlimited SIM from a friend, (also telekom) same thing here, fast in phones, slow in any 5G router, so not an Issue with my contract/data limit.

Check the bands that your phone connected to. Then when inserting the SIM into the modem set the same exact bands and speed test.

I have the same problem. With my iPhone, I have a top 5G connection, but with the GL-X3000, only a fraction of the speed. I’ve already set the band exactly as indicated on the phone, but there’s been no improvement. Has anyone found a solution?

Maybe do a modem firmware upgrade as

It was taking about another carrier but it may work for you.