GL-X3000 - VLAN Tagging

Hi all,

I'm new with VLANs but attempting to configure two of them. I have two GL-X3000's, each has one LAN port that is connected to a Netgear GS308E. Router1 is 192.168.1.1 on port 1 of the switch and router2 is 192.168.2.1 on port 2.

I'm encountering a problem when setting up the first VLAN on router1. After setting up the interface, device and firewall - as soon as I configure the switch to use the port as "tagged" I lose most connectivity. My PC is connected to port 4 and a DHCP handshake does complete, and I get an IP address however I cannot ping or access the web interface on 192.168.1.1 and internet is also lost.

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcb:cdbb:0152::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	option macaddr '94:83:c4:a3:8a:a4'

config device
	option name 'eth1'
	option macaddr '94:83:c4:a3:8a:a4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option isolate '0'
	option ipaddr '192.168.1.1'

config device
	option name 'eth0'
	option macaddr '94:83:c4:a3:8a:a3'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'
	option force_link '0'
	option ipv6 '0'
	option classlessroute '0'
	option metric '10'

config interface 'wan6'
	option proto 'dhcpv6'
	option disabled '1'
	option device '@wan'

config interface 'tethering6'
	option proto 'dhcpv6'
	option disabled '1'
	option device '@tethering'

config interface 'wwan6'
	option proto 'dhcpv6'
	option disabled '1'
	option device '@wwan'

config interface 'guest'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option multicast_querier '1'
	option igmp_snooping '0'
	option isolate '0'
	option bridge_empty '1'
	option disabled '1'

config interface 'wwan'
	option proto 'dhcp'
	option classlessroute '0'

config interface 'secondwan'
	option ipv6 '0'
	option proto 'dhcp'
	option metric '15'
	option force_link '0'
	option classlessroute '0'

config interface 'secondwan6'
	option proto 'dhcpv6'
	option disabled '1'
	option device '@secondwan'

config interface 'modem_0001_6'
	option proto 'dhcpv6'
	option disabled '1'
	option device '@modem_0001'

config rule 'policy_direct_rt'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule 'policy_default_rt_vpn'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config rule6 'policy_direct_rt6'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule6 'policy_default_rt_vpn6'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config interface 'vlan1001'
	option proto 'static'
	option device 'eth1.1'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.1'

config device
	option vid '1'
	option type '8021q'
	option name 'eth1.1'
	option ifname 'eth1'
	option ipv6 '0'

config interface 'modem_0001'
	option apn 'tfdata'
	option proto 'qcm'
	option device '/dev/mhi_QMI0'
	option metric '40'
	option roaming '1'
	option band_enable '0'
	option disabled '0'

Swapping this entry to tagged causes the issue:

Any idea what I may be missing here? Is it possible that since there's only a single LAN port on this router, it somehow conflicts with it being connected to a switch and configured as a VLAN? I'm working this problem on the OpenWRT forum as well however their support is limited due to it being a fork.

Thanks for any help you all can provide!

I do not know for sure, but it almost seems like it may only support up to 16 vlans, so maybe choose lower numbers 3-16 for vlan id (iirc, 2 is used internally). Hopefully someone else will know for sure.

Thanks packetmonkey, we're out of town this weekend but I'll give this a shot next week.

Hello,

I need a new internet gateway, and am interested in getting an X3000, but my internet provider says my gateway must support "PPPoE with VLAN tagging", not just "PPPoE". I saw your post on this forum regarding this issue. Did you get the VLAN tagging working on your X3000 please?

Kind regards,

Russell Hunter
Brisbane, Australia

PPPoE with VLAN tag is possible by default, just set the VLAN ID inside the PPPoE configuration page.

Hey Russell, I was never able to get it work for my purposes, but it's possible that VLAN tagging works for others and there has been several firmware updates since my post. I'm a fan of this product (I own 4), if the Gl-inet firmware doesn't work for you, you can always go with vanilla OpenWRT.

Hello, Many thanks for getting back to me, yes, a GL net sales manager kindly emailed me yesterday to confirm that the gateway did support VLAN tagging. So I am keen to get one and give it a go!

Thanks again,

Russell Hunter