GL-X3000 with data only T-Mobile SIM not registering

I checked and double-checked everything and I’m not having any luck getting my T-Mobile data only plan SIM to registered on my GL-X3000. The SIM didn’t come from a TMHI device, it was bought at T-Mobile store with a TMHI data only plan with a BYOD intention.

Here’s what I’ve tried:

  • upgraded router to latest (non-beta) firmware release: 4.0 0408release4
  • upgraded modem to latest firmware: RM520NGLAAR03A02M4GA
  • confirmed “Commercial-TMO” is in the AT+QMBNCFG=“list” command
  • added new cellular profile with:
    - APN = fast.t-mobile.com
    - TTL&HL as blank and as 65
    - tried with band locking off and with just 5g SA bands
  • Aborted auto connection and attempted connection via Manual Setup using new profile
  • Router reboots (cold boot)
  • Firmware resets

The Cellular area of the Admin Panel shows that it has connected to tower via a 5G band but never clears the “SIM card not registered” or the “Connecting…” boxes.

I’ve called and confirmed everything is good on T-Mobile’s end and the router even shows on my T-Mobile account with its IMEI and BYOD Router label.

I don’t have any other devices I can temporarily add the SIM to try to activate it another way.

The last unknown is if the GL-X3000 requires a SIM which has a phone+data plan rather than just a data plan.

Has anyone had any luck with this scenario or other ideas to try? Or should I call T-Mobile and change the plan on the SIM and see if that makes the router properly register?

Just using LTE, can it connect?

I tried different variations of band masking: allowing all, allowing just LTE, allowing just 5G SA. None would cause the SIM to be registered and properly connect.

Can you try this method?
If not, please share your device with GoodCloud and give me your mac address and password
Technical Support via GoodCloud.tar (192 KB)

Sorry, I followed all the instructions and saw the “ROW_Commercial” become the default profile and it remained that way after a reboot, but the SIM card still didn’t register. I also tried both T-Mobile APNs : fast.t-mobile.com and fbb.home and a mix of all bands open and then select bands, but no luck.

I’ll add the device to GoodCloud now and send you the details.

Thank you

I used a T-Mobile data only sim last fall without issue in my GL-X3000. I had “activated” the sim in a phone first to confirm that it was working. I used the default T-Mobile settings with no band locking. If I remember correctly, I had changed the IMEI on my X3000 to that of a Pixel 6a (for other reasons) prior to using the T-Mobile sim. Not sure if that had anything to do with my success. I’m sorry I can be of more help other than confirming that the T-Mobile data only sims have worked in the past with the X3000.

@doczenith1, thank you for the info. It’s likely because you activated it on a phone and then used that phone’s IMEI on your GL-X3000 that got it to work. Unfortunately, I don’t have a spare device to activate it on and use its IMEI as the router’s IMEI. I’m trying to go from a T-mobile store-bought SIM card with a data only plan right to the GL-X3000 and get it to register and connected.

You might want to consider getting a regular phone SIM and not a Data only one. I’ve set up several of these on different X3000 devices and had zero issues using the default Router IMEI. Apparently TMO has restricted the IMEI number to certain SIM’s maybe?. You could also try to find online a random IMEI number that is more closely related to iPad or Android device.

I went back to the T-Mobile store and got their modem/router, made sure it connected with my SIM, then moved the SIM over to the GL-X3000, and emulated the T-Mobile modem/router's IMEI. Once I did this, the GL-X3000 properly connected.

I wish there was a way for a Data only SIM to work without having to emulate the IMEI of another device, but that maybe a carrier issue rather than a hardware issue.

2 Likes