GL-X3000 with TMO Home Internet APN issue?

Hey Folks!

With all the help here, I was able to get the unit connecting to 5G with my tablet sim (with proper “repairs”) it is smoking! SO that test is working great.

Now the new (minor?) issue is when inserting my Tmobile Home Internet SIM into the device (with the proper IMEI repair), and setting the APN to fbb.home - the modem never connects it keeps saying it’s connecting but it never does.

The only way it DOES work is if the APN is fast.t-mobile.com - and that works REALLY well with super fast upload and download.

My question is twofold. WHY is FBB.HOME not working? AND if I leave it at FAST.T-MOBILE.COM would that be a problem with my account since it is not the Tmobile Home Internet default APN.

Any advice would be helpful. I AM ASSUMING that there may need to be another “tweak” to the modem, or modem firmware?

THANKS IN ADVANCE

1 Like

UPDATE - I THINK I SOLVED THIS MYSELF and putting it out here for the group to see.

(1) It appears that the “autoselect” MBB in the modem picked COMMERCIAL-Tmobile, which would be normally ok. BUT I seemed to remember something about selecting a generic profile in the modem.

I listed the profiles here: AT+QMBNCFG=“list”
And found a “generic looking” profile as: “ROW_Commercial”,0xA010809,202306011

(2) Used the following AT command strings.

Turned off auto select and deactivate with
AT+QMBNCFG=“AutoSel”,0
And then entered: AT+QMBNCFG=“Deactivate”

Then selected the proper “generic” modem
AT+QMBNCFG=“Select”, “ROW_Generic_3GPP_PTCRB_GCF”

Checked to be sure the profile is selected:
AT+QMBNCFG=“list”

And saw the 0,1,0 was in front of the profile at the top of the list (above TMO)
+QMBNCFG: “List”,0,1,1,“ROW_Commercial”,0xA010809,202306011
+QMBNCFG: “List”,1,0,0,“Commercial-TMO”,0xA01050F,202303091

Then REBOOTED.

I made sure the APN was fbb.home and all connected well and things are working perfectly

FOR RESEARCH SAKE, I set the system to AUTOSELECT again with
AT+QMBNCFG=“AutoSel”,1

It went back to TMO and fbb.home did NOT work properly.

So - in this case, to make sure that the PROPER APN fbb.home is working for a TMHI sim in this unit, this procedure here seems to make this work correctly!

2 Likes

CyberBobbert,

Do you know if there is an AT+ command that shows which mbn file the modem has selected for the sim card (when auto select is on)? I do not have a specific mbn file selected on my Spitz AX but the AutoSel returns a value of “1” (auto select is on). I’m curious which mbn file it’s using for my sim card.

Another question: Now that you have turned auto select off, what happens when you put your 5G tablet sim card back in the Spitz AX? Does it use the ROW_Commercial mbn file or the Commercial-TMO mbn file?

Thanks!!!

Eric

If I am correct, the MBN is the same for BOTH SIM SLOTS, but you just made me think about the fact that the SAME IMEI is used for BOTH sim profiles. I assume that is the case. Can someone verify that?

Since if we were switching form say, TMHI to TABLET you would need to update the IMEI? GOOD QUESTION came to mind!

To answer your question (when I switched SIM)

I just went back in and entered: AT+QMBNCFG=“List”

This provided this output:

+QMBNCFG: “List”,0,1,1,“ROW_Commercial”,0xA010809,202306011
+QMBNCFG: “List”,1,0,0,“Commercial-TMO”,0xA01050F,202303091
+QMBNCFG: “List”,2,0,0,“TEF_Spain_Commercial”,0xA010C00,202302071
etc…

This indicates that the “generic one” at the top of the list IS active 0,1,1

CyberBobbert,

Thanks for following up. This morning I flashed the firmware of the Quectel RM520N modem to the RM520NGLAAR03A02M4GA version. I ran a couple tests and noticed I’m connecting on a different band than before (I’m outside of 5g for my area) but with a much faster upload/download speed.

When running the AT+QMBNCFG=“LIST” command I see that the modem is using the following mbn file: +QMBNCFG: “List”,0,1,1,“VoLTE-ATT”,0xA010335,202206171. That mbn file was not present in the previous modem firmware. FYI, I’m using an AT&T data sim.

Thanks also to @Bashtech for the additional information on the firmware.

Eric

Yeah we DEFINITELY have to give serious KUDOS to @Bashtech for the details, and being the freekin’ hero here!

Glad to hear that it is working for you … and even better than expected HA HA!

Funny in my TMO case in my area, I needed to flash to new firmware to even get the Commecial-TMO for me, and then end up having to choose the GENERIC mbn to get the APN for TMHI to work. GO FIGURE … sometimes autoselect works for you, other times it may not!

Edit: I got it :smiley:
Edit 2: OK maybe not. It connected briefly, but now it’s bouncing between NSA and SA and won’t connect to anything.

I’m not having luck with this. I had to also apply the firmware (Seriously, GLINET, why is this an issue to begin with?!), but I can’t use fbb.home APN.

I don’t have ROW_Genric_3GPP_PTCRB_GCF. Here is what I see:

+QMBNCFG: "List",0,0,0,"Commercial-TMO",0xA01050F,202303091
+QMBNCFG: "List",1,0,0,"ROW_Commercial",0xA010809,202306011
+QMBNCFG: "List",2,0,0,"TEF_Spain_Commercial",0xA010C00,202302071
+QMBNCFG: "List",3,0,0,"FirstNet",0xA015300,202206171
+QMBNCFG: "List",4,0,0,"Rogers_Canada",0xA014800,202303141
+QMBNCFG: "List",5,0,0,"Bell_Canada",0xA014700,202111051
+QMBNCFG: "List",6,0,0,"Telus_Jasper_Canada",0xA01F900,202304281
+QMBNCFG: "List",7,0,0,"Telus_Consumer_Canada",0xA01FA00,202304281
+QMBNCFG: "List",8,0,0,"Commercial-Sprint",0xA010204,202111051
+QMBNCFG: "List",9,0,0,"VoLTE-ATT",0xA010335,202206171
+QMBNCFG: "List",10,0,0,"CDMAless_Private-Verizon",0xA01FD28,202304271
+QMBNCFG: "List",11,0,0,"CDMAless-Verizon",0xA010126,202304251
+QMBNCFG: "List",12,0,0,"Swiss-Comm",0xA010411,202304261
+QMBNCFG: "List",13,0,0,"Telia_Sweden",0xA012400,202111051
+QMBNCFG: "List",14,0,0,"TIM_Italy_Commercial",0xA012B00,202111051
+QMBNCFG: "List",15,0,0,"France-Commercial-Orange",0xA010B21,202111051
+QMBNCFG: "List",16,0,0,"Commercial-DT-VOLTE",0xA011F1F,202212061
+QMBNCFG: "List",17,0,0,"Germany-VoLTE-Vodafone",0xA010449,202111051
+QMBNCFG: "List",18,0,0,"UK-VoLTE-Vodafone",0xA010426,202111051
+QMBNCFG: "List",19,0,0,"Commercial-EE",0xA01220B,202111051
+QMBNCFG: "List",20,0,0,"Optus_Australia_Commercial",0xA014400,202111051
+QMBNCFG: "List",21,0,0,"Telstra_Australia_Commercial",0xA010F00,202308291
+QMBNCFG: "List",22,0,0,"Commercial-LGU",0xA012608,202111051
+QMBNCFG: "List",23,0,0,"Commercial-KT",0xA01280B,202308031
+QMBNCFG: "List",24,0,0,"Commercial-SKT",0xA01270A,202111051
+QMBNCFG: "List",25,0,0,"Commercial-Reliance",0xA011B0C,202210211
+QMBNCFG: "List",26,0,0,"Commercial-SBM",0xA011C0B,202111051
+QMBNCFG: "List",27,0,0,"Commercial-KDDI",0xA010709,202306131
+QMBNCFG: "List",28,0,0,"Commercial-DCM",0xA010D0D,202301051
+QMBNCFG: "List",29,0,0,"VoLTE-CU",0xA011561,202204211
+QMBNCFG: "List",30,0,0,"VoLTE_OPNMKT_CT",0xA0113E0,202306071
+QMBNCFG: "List",31,0,0,"Volte_OpenMkt-Commercial-CMCC",0xA012010,202209221

Am I missing something here?

Yeah this is “fun” to be sure

That Reddit post was about the suncomm and it appears that with this firmware … the ROW Commercial” is what we use not the “generic one” in that post (you have it on the second row)

Follow the instructions to turn off “auto select”, and use the ATT command to select that ROW profile. Once you do that, it should connect to the proper APN and your signal should be stable

Ask me how I know :slight_smile:

Troubleshooting is fun, right? Especially on an expensive problem like the x3000, lol.

I’ll probably mess with it again, I reverted it back. I wonder if it even matters if we use the fbb.home APN.

Yeahhhhh. A shame it doesn’t work exactly as hoped out of the box sometimes. But it appears to be something comparable with ANY manufacturer with the same 520 Modem.

Bottom line? If you try the AT command that selects the ROW_Commercial modem profile, the FBB.HOME will work as fast as FAST.T-MOBILE.COM The only reason I wanted the APN to be the right one for TMHI is … well … didn’t know if it was a problem with TMO where they would give us grief or not.

Yeah, that’s the only reason why I am fixing it. I’m worried TMO might catch on and kick me off (esp with the spoofed imei).

I am tired of fixing this thing though LOL

Honest question here. Why, exactly, would they do that? You are paying for the service and you are not abusing the service. Honestly, the days of carriers having control of your devices kind of ended with unlocking of devices.

Not sure. But we’re using spoofed IMEIs, so I’d rather not attract attention. I’m honestly not an expert on wireless, so I’m not sure how the APN being wrong affects things. I assume it’s for traffic shaping, but I don’t know.

I have done a bit of reading and fast.t-mobile.com looks appropriate for TMHI. fbb.home looks to be used for business connections. Not saying that is correct, but I have seen that in several references now.

Hmm. That’s interesting. I haven’t come across it; but I haven’t searched that hard.

Common APN’s - The Wireless Haven This is a good source but who knows if it is up-to-date.

I believe you might be right. I see more resources indicated fbb.home over fast.t-mobile.com for TMHI now that I am looking more. I saw it on a few different sites and figured fast must have been the correct one. I just took my x3000 back to my RV tonight, but I set it to fbb.home remotely. Next time I am out there I will check speeds.

If you are linux savvy, you can download speedtest from Speedtest CLI: Internet speed test for the command line. Extract, make executable, run ./speedtest, boom! Done. :slight_smile:

On side note, I still have had no luck with getting fbb.home set. No matter what, it won’t connect, lol. I did get a bandwidth boost though!

Care to share how you got it working with the tablet SIM? I cna follow bread crumbs, just need to know a little about which IMEI was used, and what settings for the Spitz.

Care to share how you got it working with the tablet SIM? I cna follow bread crumbs, just need to know a little about which IMEI was used, and what settings for the Spitz.

I had to repair the IMEI of the Spitz. In my case I ran a test with the IMEI of a broken iPhone that is not in use / will not be used. Again, be aware that depending on where you are located in the world the repairing of IMEI number may be “frowned upon”.

I then made sure for stability of the connection and all to make sure my TTL for IPV4 and IPV6 were both set to 65.

I also found that the MTU for me set to 1420 was indeed helpful for better speed and packet loss. :wink: