GL-X3000 won't tether to iPhone anymore

I’ve had this router for almost 6 months and have been tethering my phone to it through the USB port to take advantage of the 50GB of tethered data included in my phone plan. For the last few days I’ve tried over a dozen times to connect this way and it just hangs and won’t connect.

I’ve tried resetting the phone and toggling off and on the tethering option on my phone multiple times. I’ve tried connecting many times via the same button I used before on the router admin screen. Nothing works.

I went and looked in the online docs for tethering again to see if there was anything I might have missed. I saw that in the documentation it shows “eth3 (ios)” in the dropdown box where you connect via USB tether. On my admin screen it shows “eth2 (ios)”. There’s no other option to select.

Could this have something to do with why I cannot tether my phone hotspot data via USB anymore? Any suggestions as to how to get this function back? It’s frustrating to have used it without any issues for almost 6 months but now it will not connect no matter what I try.

what is the firmware version of your x3000 and ios? It work well for me with 4.0-release10403 and ios17.1. Have you clicked “Trust” on your phone? Are there any connections shown in “Personal Hotpot” after you clicked “Trust”?