GL-X3000NR - NO 5G connection for TMO?

Hey Folks,

First of all, love this community, and it was the main reason I got the Spitz AX3000! I just got it, and set up my device to work (as a quick field test) using my TMO Business Tablet plan SIM at my office (but will be using this for TMHI when I get it home)

I have repaired the IMEI appropriately, set the TTL to 64, and the APN as The unit connects to the cellular internet - HOWEVER - the speed is LTE speed (70 to 100meg), the indicator in the web UI for the device shows 4G+. I actually tried manually setting bands in various combinations (including turning OFF 4G bands) … and still I cannot get the unit to seemingly connect to the 5G SA / NSA network.

NOTE 1 - I tested a friends Suncomm unit in the same office with the same sim / plan and it DID connect to 5G

NOTE 2 - I am literally 1/4 mile from the TMO tower, and my phone and business TMHI unit are connecting at BLAZING fast 5Guc speeds so - I know I’m getting solid signal.

Bottom line? Do I need to do some AT command to “fix” the device to enable getting 5G connection? I have only done an AT command to change the IMEI and that is it. I have totally reset the unit and tried a completely manual setup, auto setup etc etc. And bottom line? WebUI does not show 5G and it won’t connect to 5G.

Advise? Thanks in advance

EDIT - I went into the “tower section” and it showed / shows NO 5GNR towers in the area (I know there is my phone is getting 700 Meg down). I locked to a 4G tower, unlocked and rescanned and BOOM it showed some 5GNR towers, but I could not lock to it and again, the device is NOT seeing / connecting / using the 5GNR towers (and the tower scan is inconsistent)

1 Like

I’ve had no issues connecting to 5G NR (n71+n41) with my X3000NR (and do not lock any bands). I use a T-Mobile prepaid mobile internet sim. Are you on the latest firmware? I’ll note that I did NOT have to manually set the APN. At some point I changed the IMEI to that of a Pixel 6a but I don’t recall any issues with T-Mobile prior to that. Did you issue the AT+QPRTPARA=1 command after the IEMI change command to save the new value?

I wish I could be of more help but I’ve never had an issue with a T-Mobile sim in the ~9 months that I’ve owned the router.

1 Like

I am on the latest firmware, and started from “stock” with no other tweaks other than IMEI and APN. I have been doing some research and it APPEARS that there may be something with the modem firmware ITSELF being a version that may not work properly for 5GNR and would require SSH into the modem to fix it - but I am waiting to hear from “smarter people than I” HA

1 Like

Did you try locking out all bands other than the 5g SA you know are available?

Well, I did a little “Googling” and found that there are others who seemed to have had this issue, and it appears to be something to do with the firmware of the MODEM itself, and the need for an upgrade there.

The solution is a bit technical for some, but it proved to work. As it was not my first rodeo in doing the SSH into a device, I didn’t feel worried about doing this. I don’t know if this is allowed to cross post to another forum (but I am figuring that I would ask forgiveness, and not permission since this also involved the instructions here at GL’s site!

(1) The description of the issue:

Bottom line? The firmware may not be “configured” (my words)

(2) Get new firmware as instructed and use the instructions to flash the modem:

I followed the procedure above, rebooted, made sure SIM / IMEI / TTL and ALL bands available (no blocking) … and when it rebooted, there was the LOVEL 5GSA indicator in the UI, and I could scan and see NUMEROUS “towers” of 5GNR. And best of all my UPLOAD and DOWNLOAD speeds were absolutely SMOKING!

Before the “fix” downloads were like 70 down / 20 up (typical 4G), but after the fix 625 down / 72 up!

This again is an issue with the modem itself, and can be resolved. BUT it would be great if GL would either flash this in all the units to avoid having to do this! I am not complaining at all. At least there is information, help and support via this forum etc as compared to other manufacturers.

PS - this UNIT ROCKS and I’m SO GLAD THAT I GOT IT !! Hope my post and eventual solution do help in some degrees!


Hello @CyberBobbert ,

Which module version did you upgrade to and get resolved, RM520NGLAAR01A07M4G_01.201.01-201?


After you upgraded the firmware, what does the AT+QMBNCFG=“list” show versus the original firmware? Thanks.


That is what was very interesting. When I first ran that command on the old firmware, there was literally nothing there, but after the firmware upgrade RM520NGLAAR03A02M4GA_2023_11_06 - I got this output below, and yes it added the Commercial-TMO as well.

+QMBNCFG: “List”,0,1,1,“Commercial-TMO”,0xA01050F,202303091
+QMBNCFG: “List”,1,0,0,“TEF_Spain_Commercial”,0xA010C00,202302071
+QMBNCFG: “List”,2,0,0,“FirstNet”,0xA015300,202206171
+QMBNCFG: “List”,3,0,0,“Rogers_Canada”,0xA014800,202303141
+QMBNCFG: “List”,4,0,0,“Bell_Canada”,0xA014700,202111051
+QMBNCFG: “List”,5,0,0,“Telus_Jasper_Canada”,0xA01F900,202304281
+QMBNCFG: “List”,6,0,0,“Telus_Consumer_Canada”,0xA01FA00,202304281
+QMBNCFG: “List”,7,0,0,“Commercial-Sprint”,0xA010204,202111051
+QMBNCFG: “List”,8,0,0,“VoLTE-ATT”,0xA010335,202206171
+QMBNCFG: “List”,9,0,0,“CDMAless_Private-Verizon”,0xA01FD28,202304271
+QMBNCFG: “List”,10,0,0,“CDMAless-Verizon”,0xA010126,202304251
+QMBNCFG: “List”,11,0,0,“Swiss-Comm”,0xA010411,202304261
+QMBNCFG: “List”,12,0,0,“Telia_Sweden”,0xA012400,202111051
+QMBNCFG: “List”,13,0,0,“TIM_Italy_Commercial”,0xA012B00,202111051
+QMBNCFG: “List”,14,0,0,“France-Commercial-Orange”,0xA010B21,202111051
+QMBNCFG: “List”,15,0,0,“Commercial-DT-VOLTE”,0xA011F1F,202212061
+QMBNCFG: “List”,16,0,0,“Germany-VoLTE-Vodafone”,0xA010449,202111051
+QMBNCFG: “List”,17,0,0,“UK-VoLTE-Vodafone”,0xA010426,202111051
+QMBNCFG: “List”,18,0,0,“Commercial-EE”,0xA01220B,202111051
+QMBNCFG: “List”,19,0,0,“Optus_Australia_Commercial”,0xA014400,202111051
+QMBNCFG: “List”,20,0,0,“Telstra_Australia_Commercial”,0xA010F00,202308291
+QMBNCFG: “List”,21,0,0,“Commercial-LGU”,0xA012608,202111051
+QMBNCFG: “List”,22,0,0,“Commercial-KT”,0xA01280B,202308031
+QMBNCFG: “List”,23,0,0,“Commercial-SKT”,0xA01270A,202111051
+QMBNCFG: “List”,24,0,0,“Commercial-Reliance”,0xA011B0C,202210211
+QMBNCFG: “List”,25,0,0,“Commercial-SBM”,0xA011C0B,202111051
+QMBNCFG: “List”,26,0,0,“Commercial-KDDI”,0xA010709,202306131
+QMBNCFG: “List”,27,0,0,“Commercial-DCM”,0xA010D0D,202301051
+QMBNCFG: “List”,28,0,0,“VoLTE-CU”,0xA011561,202204211
+QMBNCFG: “List”,29,0,0,“VoLTE_OPNMKT_CT”,0xA0113E0,202306071
+QMBNCFG: “List”,30,0,0,“Volte_OpenMkt-Commercial-CMCC”,0xA012010,202209221
+QMBNCFG: “List”,31,0,0,“ROW_Commercial”,0xA010809,202306011


When I run AT+QGMR I get the following:


Thanks for the information. I purchased my GL-X3000NR in December. Here’s the list from my router:

+QMBNCFG: “List”,0,0,0,“CDMAless_Private-Verizon”,0x0A01FD28,202212062
+QMBNCFG: “List”,1,0,0,“Telia_Sweden”,0x0A012400,202111051
+QMBNCFG: “List”,2,0,0,“TIM_Italy_Commercial”,0x0A012B00,202111051
+QMBNCFG: “List”,3,0,0,“France-Commercial-Orange”,0x0A010B21,202111051
+QMBNCFG: “List”,4,0,0,“Commercial-DT-VOLTE”,0x0A011F1F,202206131
+QMBNCFG: “List”,5,0,0,“Germany-VoLTE-Vodafone”,0x0A010449,202111051
+QMBNCFG: “List”,6,0,0,“UK-VoLTE-Vodafone”,0x0A010426,202111051
+QMBNCFG: “List”,7,0,0,“Commercial-EE”,0x0A01220B,202111051
+QMBNCFG: “List”,8,0,0,“Optus_Australia_Commercial”,0x0A014400,202111051
+QMBNCFG: “List”,9,0,0,“Telstra_Australia_Commercial”,0x0A010F00,202204191
+QMBNCFG: “List”,10,0,0,“Commercial-LGU”,0x0A012608,202111051
+QMBNCFG: “List”,11,0,0,“Commercial-KT”,0x0A01280B,202111051
+QMBNCFG: “List”,12,0,0,“Commercial-SKT”,0x0A01270A,202111051
+QMBNCFG: “List”,13,0,0,“Commercial-Reliance”,0x0A011B0C,202210211
+QMBNCFG: “List”,14,0,0,“Commercial-SBM”,0x0A011C0B,202111051
+QMBNCFG: “List”,15,0,0,“Commercial-KDDI”,0x0A010709,202111051
+QMBNCFG: “List”,16,0,0,“Commercial-DCM”,0x0A010D0D,202208151
+QMBNCFG: “List”,17,0,0,“VoLTE_OPNMKT_CT”,0x0A0113E0,202204211

It looks like there are several more additions to the firmware version you’re running. Might have to upgrade this week. Thanks!


I provided the solution in the Reddit thread.

RM520NGLAAR03A02M4GA is the version that resolved our issues. I am not sure if there anything newer, this one is dated 2023-11-06. It was the latest one I could source.


THANK YOU FOR YOUR SOLUTION! It worked wonderfully!