GL-X300B (Collie) SIM Card not registered

I just bought a GL-X300B (Collie) and don’t get any mobile data connection.
The 3G/4G modemshows the carrier but keeps saying “SIM card cannot be registered”.

I searched the forum and tried the following thing:

  • AT+QPRTPARA=3 command on /dev/ttyUSB2
  • QMI mode on /dev/cdc-wdm0
  • PPPD Dial on /dev/ttyUSB3
  • tried several options on APN settings as I found for O2-de (Auth = PAP)
  • tried 2 more SIM cards from different carrier (only one with PIN which was requested by the modem)
  • tried all 3 sim cards on mobile phones to clarify that they work and do not need PINs.
  • the SIM card was also tested on a HUAWEI 4G router and works flawlessly

Firmware is 3.215
Antennas are connected.

This is a brand new router. Could it be defective? Or am I just doing something wrong?

Best regards,

Which carrier does your SIM card belong to?

The one I’d like to use belongs to german O2-de.
The other two I tried are Vodafone and Congstar (telekom carrier, I guess)

Very strange question, I suspect the antenna is not connected properly, can you open the metal shell to see the antenna connection? It is best to take a picture of the connection between the antenna and the modem.

Thanks for the feedback.
I tried to open the shell but the screws are really tight and two didn’t move.
As I am on tour right now I will try it back at home with some better tools.

However, as you asked about the Antennas, I noticed that the external connectors are quite loose. They can be easily disconnected by slightly pulling the cable. Only the GPS and one 2.4GHz connector feel more “secure”.
Is there something I can do?

Hi Apfelsafft, I will help you solve this problem, I want to get the device MAC address from you, and please give a picture about you say antenna loose, MAC address private information, so can you send these information use email? My email is