GL-X300B Much slower than Franklin t9

Band 25 rsrp -94 rsrq -8 rssi -77 sinr 18 for the gl-inet. the t9 gets like -103, -13, -79, 21. T9 speed is like 25 up 4 down and the gl-inet is like 10 down 4 up both have been tested on WiFi and Ethernet and both get pretty much the same speeds

rsrp -94 seems not bad. But can you post the full cell info which you can just copy from the UI?

[
{
“type”: “servingcell”,
“state”: “NOCONN”,
“mode”: “FDD”,
“mcc”: “311”,
“mnc”: “490”,
“cellid”: “7E0960A”,
“pcid”: “67”,
“earfcn”: “8265”,
“band”: “25”,
“ul_bandwidth”: “5M”,
“dl_bandwidth”: “5M”,
“tac”: “A2E5”,
“rsrp”: “-97”,
“rsrq”: “-11”,
“rssi”: “-70”,
“sinr”: “18”,
“srxlev”: “-”,
“rat”: “LTE”
},
{
“type”: “neighbourcell”,
“earfcn”: “8265”,
“cellid|pcid”: “67”,
“rat”: “LTE”
}
]

I found the following figure.

5M bandwidth can achieve 18.3Mbps for CAT4 and 36.7Mbps for CAT6.

Seems for X300B the speed is normal.

Maybe your T9 is cat6? Is there a detailed model number?

Ok so on this website it shows that the t9 has the MIMO2x2 https://www.rvmobileinternet.com/gear/t9-mobile-hotspot-franklin/ I bought a router slower than my current one didn’t I. Do you know if I can replace the eg25-g with an epo6-a

If you change to EP06 it will work. But you need to add on antenna as well.

X300B is designed for IoT, not for performance. It has metal case. So if you use two antenna for LTE, you will not have any antenna for wifi.

So if I put the epo6-a in would it automatically start using the WiFi antenna as another cellular antenna or would I have to add a new one somehow. If I have to add a new one how would I go about doing that? Also just in case I forget to say it later thanks for all the help

Ok so I took it apart and I understand what you mean now but the 2.4 antenna cable would be too short so do you know where I could get a longer one

You need to find another 4G antenna. It is very common.

WiFi antenna cannot work for you.

What should I look for specifically? So far I’ve only seen the large outdoor ones and one that looks close but it’s for
WiFi would this wire work? https://www.amazon.com/U-FL-RP-SMA-Pigtail-Antenna-Cable/dp/B005UWD0EG

You also need to have a stick. Pls confirm with the seller if they have the stick and uFL wire.

https://www.amazon.com/Antenna-Connector-Omnidirectional-Verizon-Wireless/dp/B07YWHFQ6L/ref=mp_s_a_1_19?dchild=1&keywords=4G+antenna+set&qid=1627998357&sr=8-19

Could I buy the one cable I sent you and the antenna you sent me since they’re both just sma male and female because the seller for the antenna doesn’t have the cable and the cable seller doesn’t have the antenna as far as I can see.

You may just ask our customer service to see if they can get you one set.
cs at gl-inet.com

Alright so when I get everything I can just put it all together and it will work or will I need to do anything with the software?

The software support both EC25 and EP06. If you install two antennas you will lose wifi.

Alright cool thanks for the help

Hello again I now have all the new stuff set up and the download is now about 35 so thank you for the help with that. I’ve also gotten the signal strength to around -88 consistently. My upload is just slightly less than I would like as I would like it to be at around 9 and it’s currently sitting at about 4. If it’s not too much trouble would you be able to give me some tips to increase it slightly.

You can refer to this post and find the troubleshooting part North American Carriers, ATT, Verizon, Cricket, T-Mobile Setup and Update 2021

You can use the settings as suggested in the images. The settings works for the world.

Ok so that helps my download get 5mbps better and my upload 2mbps faster by setting it to qmi. For some reason the qcm is slower for me on download and upload. Thanks for taking your time to help me again. Anything else I should do from that guide you made?

No need to do other things.