GL-X750 Bricked UBoot partition still SSH/Luci access

Hi friends. Log story short, I’ve been experimenting with the ROOter/Golden Orb firmware got it to work well on my GL-X750, however its missing WireGuard VPN and seems to randomly lock up once a day requiring a reboot. No big deal, I downloaded the original GL firmware and attempted to flash back to OEM. The firmware image uploads via luci and proceeds as if everything is installing, however after reboot the old firmware and all the settings are still in place and working as if nothing happened.

I started looking at Uboot option but never was able to load the web UI. I’ve set PC ip to and could ping but no UI. Thats when I found the thread on this forum regarding UBoot issues and downloaded the UBoot image from github and was able to access After pushing in new uboot image upon restart in recovery mode after five flashes the recovery light comes on for about 2 seconds and disappears. During this time I can ping but it quickly goes away.

So here I am stuck with working firmware but no uboot to flash back the OEM firmware. Can anyone suggest any way to recover uboot partition in this situation?

Hm, prob not going to work since ping is basically dying, but have you tried playing with the MTU?

Seems to helped here somehow: Bricked AR300M, how to restore? - #6 by is9aes1o

Would TFTP be an option? Any chance you could run a packet sniffer and see if the device is trying to reach out any sort of way?

MTU issue seems to be related to linux based workstations, but I’ve tried to limit MTU to 900 on my laptop without any results. Yeah, I’ve searched the forum and followed few threads. It seems like evrything working well it’s just I cant apply any other flash update. I’ve tried via luci and SSH, everything runs and looks like taking effect and when router reboots same Rooter/Golden orb configuration.

Hrm, ive played around with that firmware as well on the GL-MT300N-V2 guess I got lucky. Maybe run wireshark or something and see if the device is looking for a TFTP server.

I’m in the exact same boat. OEM software was running, then installed ROOTer/GoldenOrb. Was having issues and tried to revert back to OEM. Router seems to go into U-Boot mode (globe led is lit after five flashes of WiFi led when holding reset button during start up). But can’t connect through the browser (
Haven’t tried updating U-boot but it sounds like doing that didn’t work for you either.
Any progress?

Uboot should be OK. Can you make sure you are doing the correct steps.

  1. Only connect one cable, from your PC to the LAN or WAN port. Do not connect another cable.
  2. First connect cable, then hold button and power on. After entering uboot mode, change your PC’s mac address to
  3. If one browser does not work well, try another, e.g. Firefox.

@alzhao @Grindkore
Was able to get to the UBoot ui and successfully flashed back to the OEM interface once I dug out my PC. Was trying earlier on both my Mac and Raspberry Pi. Seems odd that something that communicates via a browser would be OS dependent.

At any rate, looks like we’re back in business!

1 Like

@alzhao Do you know if it’s possible to use UBoot through a Windows virtual machine? Or if there’s some other way to get it to run on Mac/Linux?

It should work with windows and linux. The key problem is the Ethernet chipset and driver.

Virtual machine does not matter really because it is the host system dealing with the connection.

Doing all that, my problem is that the globe led lights up for only for few seconds. After that there is no IP connectivity. I’m currently stuck with ROOter/GoldenOrb otherwise everything works.

Wish i would have read this be for i loaded rooter

easy once i used edge browser

1 Like

Now that i have the old firmware in how do i getmy gui back