GL-X750 Only 1 cell after firmware upgrade

Have had the GL-X750 for 3 months with no issues, using AT&T LTE towers. I recently upgraded to firmware V3.203 and everything seemed fine. I then began to notice that our speeds seemed much slower than usual (~30Mbps slower). Rebooted the GL-X750, checked antenna connections etc. Seemed to resolved it but eventually kept happening. Yesterday, I noticed in the Admin Panel that only 1 cell was showing up under cell info where I used to have 4 cells. Seems that I am no longer able to connect to a LTE tower?

Tried reverting the firmware, going through setup all over again but no joy. Installed previous version of firmware, same result.

Not sure what else to do at this point.

It seems this is 3G, not 4G.

It may not be the firmware. For some reason the modem works in 3G mode. Can you force it to be 4G?

Choose network mode

set modem to only LTE

echo -e "AT+QCFG=\"nwscanmode\",3,1" > /dev/ttyUSB2 

set back to auto

echo -e "AT+QCFG=\"nwscanmode\",0,1" > /dev/ttyUSB2

Thanks for the reply but I am getting an error when I attempt to run that command

I could not find anything in the logs that would indicate why this does not work.

I am using EP06-E and just tried it works. I don’t know why it does not work with your EC25-AFFA.

Just check one more time the format is totally correct as below.

Choose network mode

set modem to only LTE


set back to auto


Same. UI just says Error as in screenshot above. Are there logs I can look at that would give more details as to why it will not accept the command?

Should I reset the router (although I have tried this before). Again, this was working fine until I updated to the latest firmware 3.2.03

Using the UI, the command should be entered as


Figured this out by doing command


which will let you know if the command is supported and give you the syntax for the command.

Now connecting with 4G.

1 Like

You are right. The original command is for shell so syntax is different.

But pls note the double quota should be "

The correct one should be


Many x750 owners are experiencing the same problem. There is a compatiblity issue between ATT and x750. Nobody knows if this is a temporary or permanent problem. Read this:

and then this:

Executive summary: the x750 situation may be part of their phase out of all 3G service. The x750 may never connect at 4G again, and in feb 2022 it won’t connect at all. If you want to stick with ATT, it appears your only option is to buy a netgear nighthawk hotspot.

Either buy a new router, or switch carriers.

Firmware fix has already be out GL.iNet download center

Will release by the end of this year

This appears to be the same firmware you told me to try before. It did not fix the problem.

The firmware fix the problem of ATT that will happen in Feb 2022.

The problem should not happen now. If it happens, it is a different problem.

Maybe you can try to lock 4G as in this post. Seems it works for @knights