GL-X750 OpenVPN - do not use VPN as default route


Here’s what I’d like to accomplish, but have not been able to…

I have a GL-X750 on a remote site that connects to my local OpenVPN server. In principle this is working fine and I can access the remote devices ( from my LAN (

However, I only recently discovered that all traffic on the other side goes through this VPN tunnel, which is not what I would have expected. My sole intention is that I can access the remote clients through this tunnel but nothing else. All remote traffic should go through the normal 3G interface. Furthermore, the DynDNS should return the 3G public IP and NOT the IP of the OpenVPN server!

I also tried the “solution” suggested in this thread: Openvpn configuration to avoid the default redirection (all through the VPN)

However, after applying the workaround, I could no longer access any remote device.

I’m kind of stuck here and would appreciate any help…

But you can also use vpn policy in the client side to not use vpn for all clients.

What would that look like? I tried as follows but that didn’t work:

Alright, the following seems to do the trick:

Very interesting. But I don’t know why the first one does not work.

As expected, this does have side effects, though. For example, I can no longer reach the router itself (i.e. with these settings. :frowning:

So only reset will bring back the web panel access.