GL-X750 suddenly stopped working

Hello. I would like to ask for assistance please. I got my Spitz 4 months ago via gl.inet web store and it just stopped working.

The product was working fine as usual (connected to net via LTE modem, LAN cable to PC and 5G wifi on, latest stable firmware) when I suddenly lost internet. I thought there was an issue with the cell network, so I tried to log in to the router to reset the modem connection. To my surprise, I was unable to reach the router (via 192.168.x.1). When I glanced to the physical router, I was surprised again when I saw that the Wifi and LTE lights were turned off and the only LED indicator lit up was the one for Power. I turned the router off and on, and it got even weirder. As soon as plugged in the router, the Power and WAN lights turn on (note: I have never used the WAN port prior to this and the WAN LED indicator lights up even though there are no cables plugged in both LAN and WAN ports). I have tried holding down the reset button for 3 secs, 10 secs, and even tried 30-30-30 reset multiple times… All to no avail. Most of the time when you turn it on, both the Power and WAN lights will be lit but on some rare occasions only the Power light will be lit. Also, important to note that I am unable to connect to the router. Wifi is down and I’m also unable to reach the router using both LAN and WAN ports (even during when the WAN LED indicator is lit).

Hopefully someone can assist with this issue. I will also shoot support an email (for warranty, I suppose) but I am hoping that there’s an easy way to fix this as I can’t afford to lose my router for an extended period of time. Also, it’s for peace of mind as never can tell if this will happen again even if I receive a replacement. Never had any issues before this happened so this has been very disappointing as I am unable to troubleshoot it on my own and the product is almost new.

P.S. for warranty, will the company shoulder shipping (both sending defective product and receiving replacement)? This is another thing that’s on my mind.


Edit1: To further clarify: The computer is actually unable to detect the GL-X750 when the LAN cable is plugged to either GL-X750’s LAN or WAN port. The PC and LAN cable are not the issue as I’ve tested with an older router and the PC was able to connect effortlessly.

Mmmnm, if it was me, the first thing I’d be trying was to reload the latest image via uboot …

That was also the suggestion I received from tech support and I’ve already tried (for hours as I rly need the device) with no success.

I’ve sent over my detailed findings to them but to summarize:

  1. I’m barely able to trigger failsafe mode. I follow instructions properly and can’t really get it to work at will (it’s random and issue could be related to the fact that the PC doesn’t normally recognize the router)
  1. Less than 10 times I was able to trigger failsafe (blinking light) and PC recognized a router was connected. However most of the time I can’t access
  2. Twice I was able to access but not able to proceed and the page stopped loading. Waited 10 mins and confirmed no changes
  3. Once (my latest “success”) I was able to get it to reach the update in progress page. Waited 10 mins and no visible change in the router. Unable to access .1 and .8 on PC so I restarted router w/o attempting to trigger failsafe and to my surprise PC detected router and I was able to enter the .8 site using my old pw with settings intact. But upon checking fw version is still 3.009 and not 3.026 wc I loaded in uboot just 10 minutes ago. Restarted router to insert my sim card and it stopped working again. Unsuccessful attempts to trigger debrick mode again since.
  4. OS is Windows 10 and I’ve attempted with browser cache cleared

In hindsight, should’ve attempted to update fw again when I entered .8.1. But like usual, very difficult to trigger failsafe. There could be something wrong with the LAN/WAN ports/module (among others) which mess everything up and hinder triggering failsafe mode. As stated, PC normally can’t detect router (network cable unplugged) and when I do manage to trigger failsafe, PC can’t establish proper connection to router. Also, it is very weird that when I turn the router on, sometimes both Power and WAN LED lights are on and sometimes it’s just Power light (although result is the same).

Unfortunately, seems issue is not fixable on my end as I was asked to send the device back and will be issued a replacement. Hopefully I was just unlucky as I have not seen similar problems on the forum.

Good news though for those wondering about warranty. GL will take care of shipment costs.