GL-X750V2 Spitz eMail smtp server config

I am trying to send an email through my own email server and it isn’t working. I don’t have accounts with any of ‘the big names’.

The instructions suggest that I can set the Protocol for the selected port, but I am unable to do this, the Protocol box isn’t there. I set the smtp server settings the same as used in my Thunderbird eMail client, and I have also tried all the usual ports - 25, 465 and 587, but none seem to work.

Any suggestions?

Firmware version 3.215. (I have a feeling, I couldn’t set it up in 3.212 either.)

The field ‘protocol’ here is described with:
“protocol: Encryption protocol.”

If it is your own server, you should have no problem to get the log files and see why your mailserver isn’t accepting the connection. If the issue is ‘no supported encryption’, the missing box is an issue.

But I am a little concerned of the try of different ports. You should know (not try) what port your mailserver is using.

Second: you want to send emails, there is no word about forwarding SMS in your text. But the manual is about forward SMS … Do you think you’ve got the right manual?

Most times I have to support email issues, the problem is the wrong use of the ‘Host’, ‘Domain’ or ‘Server’ field different words for all the same).
[protocol://][hostname][:port] is very common, but in the screenshots of your link is just [domain][:port] in the example.
So it should be your domain.tld:25 (or instead of 25 the port your email server is configure to. See documentation).

Nowadays, applications and devices may infer the SMTP protocol from the port number and/or auto-negotiate the protocol. Port 25 is essentially obsolete with no encryption. Port 465 is probably SSL encryption. Port 587 is probably TLS encryption.

Since you have your own email server, you should be able to find how which SMTP protocols are supported (could be multiple protocols) and check if they match those port/encryption combinations. Another thing to check is whether your email server requires OAuth2 authorization.

I do not work for and I am not directly associated with GL.iNet

Thank you both for your assistance and pointers, much appreciated.

I have already checked everything except doing a telnet. All spellings and passwords visually double checked (copied and pasted from Keepass), and also typed in manually. SMS messages are working OK. The link shown is the link pointed to in the '‘Please follow this guide’ link on the Router SMTP settings config box.

Firstly, a sanitised screenshot of my working email client (setting work for Linux, Windows, Android and IOS).

Now my Router SMTP config box.

Finally, a screenshot of a telnet test on port 587 of the eMail server

The email server /var/log/mail.log shows no connection from any device other than the ones trying to connect to the server mail every 10secs (fail2ban takes care of them!). This could mean a problem with the router config, or the MVNO (Lebara), however, I can send emails from other devices.

You can see that I have no ‘Protocol’ box showing, and I guess my question is…

‘How do I know the eMail is being sent correctly, using the correct port and security protocol?’

With no connection to the email server, it suggests that either the email is not being sent, or there is something wrong with the protocol. Unfortunately, the GL.iNet Guide tells me to select the protocol, but the option isn’t available on the page.

Is this an oversight in the instructions for updated firmware?
Or, is my firmware not loaded correctly?
Or, does firmware version 3.215 recognise the port and use the correct protocol?


Oh, also tried this originally with Wireguard. Also tried openVPN, but currently using NO VPN.

Can you look in the router’s System Log (logread) to see if a verification email is recorded as sent out as a test?

Also, you can try forwarding as a text message to your phone to see whether that works at least.

1 Like

Just had a quick check of System Log (LUCI) and see some anomalies, but need to spend some time analysing as I am getting some ‘different’ messages for the same thing. This will have to wait until tomorrow.

Sorry, thought I mentioned, SMS works fine.

Thank you for the pointer as to where to look for log.

Investigated and hopefully I have got further.

Here are the continuous Hack attempts at the server…

This is the connection attempt, from the smtp server log, by the GL-X750

Finally, the log from the GL-X750

My interpretation of this is that my email server cannot service calls with Encrypted passwords. My eMail clients all use plain Passwords and when I attempted to connect with an encrypted password, It didn’t even attempt to connect to the server, or at least, it didn’t get as far as being logged…

I guess now my question is @alzhao ,
As we can no longer choose the Protocol for SMTP, what method does the router use to send password to SMTP server, NORMAL or some form of ENCRYPTION?

I have looked in ssmtp.conf and both removed AuthMethod and also set AuthMethod=PLAIN (default AuthMethod=LOGIN).

Not sure where to go from here. A new server install is on the cards for the longer winter evenings, but, I think I will bring it forward.

It actually use encrypted protocol to send info.

Have you tried public servers which you can choose directly in the list?

I am afraid that I don’t use Google, Microsoft, Yahoo or Apple (and many others) as far as possible.
Whether people agree or not, my philosophy is that, as far as possible, my data belongs to me, and is not to be monetised by someone else.

I do have a couple of sub optimal options that I might be able to utilise, but these would not be the preferred solution.

Is there not a way to change the protocol within openWRT?

(I shall carry on investigating, including a new server, but any pointers appreciated.)

1 Like

I am not sure. But I think there should be she’ll script releases to this part.

1 Like