GL-X750V2 Spitz (EP06-A) Bandwidth Question

Hi all,
I have a GL-X750 (EP06-A), I am using a Visible/Verizon SIM. Since I plan on using this setup occasionally while I am on the road for work. When I need it, I plan on taking my SIM card out of my phone, and putting it into the GL-X750V2.

I am reading, tinkering, and testing. I think I have this thing setup the best it can be, but the amount of bandwidth seems weak. My thought was that I can test my setup by streaming some video from YouTube TV. The max resolution I am getting 820xsomething, and a bitrate of 2.2mbps. I am seeing this info in the geek stats in the app from a Roku box. When I do a google internet speed test I am getting around 18mbps up and down. I would expect the resolution to at least hold at 1280x270 with some decent bit rate.

Here is how I configured the GL-X750V2, after updating to the latest firmware.

  1. I cloned the IMEI.
  2. AT+QMBNCFG=“List” to find and select the generic one.
  3. From what I’ve read her on the forums, one band may work better than others. In my testing at my house, band 5 seems to be working the best. Below is what I pulled from the cell info tab.
  • Rsrp -91 Good
  • Rsrq -11 Good
  • Rssi -66 Excellent
  • Sinr 22 Excellent
  1. I have the TTL set at 64, and the MTU set at 1428
  2. In my testing, /dev/ttyUSB3 seemed to work the best.
  3. I’ve read that VSBLINTERNET should be the APN, and in other places VZINTERNET should be the APN. I cannot get VSBLINTERNET to work, so I have been using VZINTERNET.

I am looking for some advice.

  • Perhaps this is the best this service can do? Maybe I need to try another provider?
  • Maybe my testing method is flawed? I have a personal phone with Xfinity mobile service, and running a speed test from my phone in the same spot gets me 75mbps download speed.

Before Visible network use VSBLINTERNET as apn. But recently a lot of users report that this changed to VZINTERNET.

For speed, try cdc-wdm0 and qmi or qcm to check.

Hello Alzhao,
Thank you for the reply.

I am on firmware version 3.215.

Under devices I have /dev/ttyUSB0 though USB3. I do remember seeing the cdc-wdm0 option before, I tried that but it did not seem to help. From what I remember I ran a reset command I picked up in another forum, and that option went away. I am going to just re-run the firmware update and not keep the settings. Hopefully that gives me a fresh start.

I do not see a qmi or qcm dropdown option, but I did find a command that should let let me do it.

option proto ‘qmi’

I do have a question. I assume I run that command against the device I want to be in qmi or qcm. So in the AT Command field I would type option proto ‘qmi’. And in the port I would select the cdc-wdm0 port once I get that back. Is that correct?

From your screenshot, your AT command is not correct.

Maybe I can do a remote check. I will pm you.