GL-X750V2 Spitz installing and using openssh

I have installed luci, and have installed openssh. How do I actually enable openssh on boot to replace the dropbear server?

If I uninstall dropbear, then for reasons I don’t understand ssh login doesn’t work at all.

Thanks in advance!

1 Like

I suggest that you don’t uninstall dropbear - it can be problematic when you do upgrades.

Here’s how I do it in OpenWRT:

  • Change the dropbear port (I use 2222) - I’m usually lazy and just do it in LuCI - System > Administration > SSH Access (tab)
  • SSH into the router (e.g. ssh -p 2222 root@
  • # opkg update
  • # opkg install openssh-server
  • # /etc/init.d/sshd enable
  • # /etc/init.d/sshd start

That’ll install/start openssh and the “enable” will run it on every boot; it’ll be bound to port 22 by default. Next, verify that you can ssh into the router by ssh-ing in again on the default port 22 (e.g. ssh root@ Once you’ve verified that its working, you can OPTIONALLY disable dropbear (it uses next to no RAM or CPU when not in use - so its kinda nice to leave it running for at least a few days just in case something bombs):

  • # /etc/init.d/dropbear stop
  • # /etc/init.d/dropbear disable
1 Like