Gl-x750v2 Spitz REST API


I wonder if anyone can help.

New to the router, but I am trying to use the REST API to get information from the X750V2 Router, and although I can get my token using CURL, I can’t get anything other than Error 0: from the Router.

I have changed the IP address in the REST API page and added my token aabbccdd112233eeffgg in the box, even tried it with quotes, but it doesn’t make any difference.

What am I missing? Is there anything I need to enable?

Firmware: V3.203


Managed to get a CURL command to work…
curl -H “Authorization: aabbccdd1122334455eeff” --cookie “QSESSIONID=9177564b1203c30000”

I have another observation to make.

Should the Authorisation token change every time I request it using the Curl command?

I just used the following and it has response

curl -H “Authorization: 421cfc4c9b0949b2bcf8aa312cbe3ee77”

For the API you tried it actually need input data.

Because we redesigned the API to 4.0, so we will not do more support on 3.0 api anymore.

Are you saying that the REST API page with the boxes for input does not work?

I was trying to use the API page to fetch the results of the API calls that interested me. This would save me writing the commands manually each time during testing.

I can get the API to work using Curl, but not all API calls seem to return a result.

If there is a redesign, when can we expect to see API v4.0 to be released? In the meantime v3.01 is all we seem to be able to work with…

Is this value persistent until the next token request, even through switching off and on??
What circumstances cause the token to change?

Sorry for the questions, just trying to get my head around your implementation of the REST API.

The token is gone when you reboot, or relogin.

Using the api on the web page directly seems has problems.

Just to let you know that I am able to use Node-RED to make the calls and handle the responses that I am interested in.

Thank you.

1 Like