GL-XE300 Beta 4.2.2 Issues

Installed 4.2.2 and have noticed the following issues so far. The cell issue being the most critical:

I am unable to connect to a cell network. It just continues to show connecting. I was able to connect using versions 3.215 and 3.216.

The battery symbol showing the remaining capacity is the “charging” icon when running on battery on both the Internet page and the System → Overview.

1 Like

Thanks for the feedback, will fix

Do you have an ETA for the next beta.

Now trying with the latest 4.3.2 beta1.

Still the same unable to connect to cell network. Continuous “Connecting”.


Which carrier’s network are you using?

When running under 3.217 the modem screen shows: Orange PL

And I’m in the US.


I downloaded 4.3.2 beta1 compiled 2023-06-04 04:27:33 (UTC-04:00) but I don’t see Tailscale in the applications?

Can export system logs when a problem occurs? You can export it in System->Log

The XE300 CPU can hardly support tailscale.

Maybe remove the XE300 form the list of Tailscale supported hardware, I spend quite a lot of time chasing it. (93.5 KB)

Added the .zip to allow upload.

Logs as requested.


And then 15 minutes later when I tried again, it connected. LOL

This time I selected Manual → Use Other Settings → Apply I did not change any of the suggested parameters.

I had tried manual previously and couldn’t get it to connect.