GL-XE3000 doesn't register SIM-card

HI there,
I just bought a GL-XE3000 for using it with my SIM-Card for 5G-usage. the SIM-card worked flawlessly within my Mudi (v1)-modem, where it connected happily with it’s connectivity Provider (German) Telekom.

On the new model I only receive “SIM card not registered”. I can switch the SIM back to my Mudi-Router and I get good LTE-connection, so there is no locking on the SIM-card itself. I tried the SIM card within my iPhone 12 Max and it was able to connect with an 5G-Connection, so the plan supports LTE.

what can I do to locate the problem? on luck I see that the modem has an unsupported protocol type, but there is no luci-proto-Package offered. I do not know whether this is needed.

Admin Panel Version is 4.0, latest firmware installed, Kernel version 5.4.211. OpenWRT is 21.02.SNAPSHOT r15812+879-46b6ee7ffc.

best regards, Hanno

I think yesterday we pushed 4.4.8. Can you check if you have updated to this version?

Also try upgrade the firmware of the modem. Check this post GL-X3000NR - NO 5G connection for TMO? - #5 by CyberBobbert

1 Like

that was a fast response - thanks! I’ll try the new firmware and the mentioned update of the modem and report back :wink:

1 Like


I updated the firmware to 4.4.8 and I upgraded the firmware of the modem Unfortunately, I still get the message “SIM card not registered”.
while updating I said to not remember any configuration on that device, so I had a restore of default values. when I inserted the SIM now, apparently the Telekom-Profile got recognized and their profile is used (QCM, internet.telekom). But still the card can not be used.
when I try to scan for a tower, I see an LTE tower (262-02 32AB902). Which is interesting since my iPhone sees 5G, not only LTE.

When I use an AT Command for receiving the Signal Quality (AT+CSQ) I receive:

+CSCQ: 99,99






+COPS: 0


How about this one GL-X3000 Spitz AX - 15 Mbit/s with 5G - #28 by EricG

Try this

thanks for the hint. Unfortunately, that didn’t help either.
Even open the bands and select Nan LTE and NSA bands didn’t help

Interestingly enough, I only see half of the screen you all seem to see. I’ll try to upload a screenshot:

Can I see it remotely?
Technical Support via GoodCloud.tar (192 KB)

I sent you a message with the credentials, thanks for your help!