GL-XE3000 Puli AX Cell Access (O2, T-Mobile) Germany

Dear All,

I just received my XE3000 and tried 3 SIM Cards from two carriers out. APN configuration was done for the respective carriers (O2 Telefonica, T-Mobile) but non of them connected to the internet.
Can I enter MCC, MNC and APN Type somewhere? It is not shown to me in either web nor cellphone interface.

Upgraded to latest firmware (4.4.4) all SIM cards work flawlessly (with the tried configuration) on my cell phones.

Thanks a lot,

I also tested in my Lenovo Thinkpad and both cards work out of the box (just PIN needed). So it cannot be the SIM cards.

On the INTERNET page, do you see the Lock Tower icon (in between SMS and Signal)?
When you click on it does it search and find and show required carrier with its MCC MNC in the Available Tower list?

I have the following view within the lock tower screen:

Assuming the Tower Names start with MCC I recognize 262 for the carrier “O2” but I don’t see MNC 07 somewhere.

Refering to the connection settings from O2

Shouldn’t the router connect to the right tower automatically? I tried to lock to all of them manually but this didn’t result in any internet connection.

Thanks a lot for your help.

O2 Settings (couldn’t add more than 1 picture to the post. used google translate to the right picture.

@freemanJ : mcc is mobile country code and mnc is mobile network code. I don’t know if O2 is supposed to show up as 2627. One thing you could try is add option plmn ‘262007’ to config network ‘network_sim1’ in glmodem file in /etc/config (or pehaps to config interface ‘modem_0001’ in network file in /etc/config). Then do uci commit and /etc/init.d/network restart and perhaps reboot. Of course if no O2 is recognized or found that may not help and such config must also need to be removed when trying to register to elsewhere perhaps with another SIM to another carrier. One can save specific SIM setup in a profile.


I’m in Berlin right now using my Spitz AX with an German O2 data sim. I set the apn to “internet” and the sim card connected after a couple of minutes.

I did not set any other field other than the apn name.


Hey EricG,

I tried this as well - but it doesn’t seem to work. Will change the router location to see if this helps. Which is the standard Port? /dev/mhi_DUN as in the screenshot?

Hi tasinofan,

Thanks for the answer - just to ensure we are on the same page. I would connect to the Puli AX via SSH on LAN / USB and modify the files as suggested, right?


Here’s what I have for manual setup:

Protocol QCM
Port /dev/mhi_QMI0
APN Internet
PIN Optional
TTL Optional
HL Optional
MTU Optional
Authentication NONE

I updated the quectel modem firmware to RM520NGLAAR03A02M4GA and I am on GL.iNet firmware version 4.4.6

1 Like


I’ll also add that I was using my Spitz AX in the US with an unlimited AT&T data sim. I’m in Berlin for a couple weeks and am using a German o2 data sim in the Spitz AX. I did not change any country codes. Just put the sim in and was up and running.

I set the IMEI to an old Netgear LB1120 that I had (4g/LTE modem for the US). In Berlin I’m connected to 5G NSA.


@freemanJ : I do work in CLI from ssh to LAN interface.

@freemanJ silly suggestion perhaps … did you try without PIN. I apologize if that does not help, I would not claim it helps, but I always run mobile hotspots with SIMS that have PIN removed.

1 Like

Thanks tasinofan and EricG, it works now.

I applied the settings as depicted and removed the SIM card’s PIN by phone and put the SIM back into the Puli AX. For some reason I can connect now automatically to the internet by cell.

Will also update the modem’s firmware just to be on the latest SW revision.


1 Like