GL300M with bridging over wireless

Using a GL.iNet GL-AR300M (NOR) with firmware version 4.3.11,
I tried to access a existing wireless network (wlan). So the GL.iNet would have access to the world.
After this, the ethernet port should be free to use.

This is realised by repeater mode, I read.

But this does not work properly.

1.) I tried with my laptop, plugged ethernet cable at the lan port of GL.iNet.
There I will get a IP from the giving wireless, so all well. But the laptop has no connection, and the GL.iNet also says, it is connected but has no connection.

2.) Okay, this I tried to access to the web gui of the GL.iNet, there is no access. Okay, I used the fixed 192.168.8.XX range of IP addresses, so yes, I can access to the router. But also no access to internet.

Looks like the lan port does not work in repaeter mode.

The scenario I want to use is getting a connection from an existing wirless/wlan and giving thi sto a lan port, so for example connecting a wired ethernet to a printer.

So, why the web gui does not serve a option “accessing wireless” as a router mode?
I can not find out how to use this. Or is there a bug?
I think, I made this case a year ago with another AR300M, and it worked. But I can not have a look at this old case any more.

Please give me a hint. Looking forward to your help.