GL750M won't boot

The fun with gl-inet routers never ends…

I have a gl-AR750S-EXT (it’s dark gray, so maybe a "Slate?) that has been working fine for a couple years - or at least well over a year. Yesterday, it stopped outputting any power to the output port (USB Type-A to the phone). Only the power light was on.
Unplugged it, plugged back in, same thing.
Switched it to a DIFFERENT 2.4A power supply. Same thing.
Tried repeatedly.
Is there some method for getting this thing to boot and start working again, or is it DOA?

S’too bad, 'cause other than the fact (admitted by gl-inet) that it won’t output enough current to keep the cell phone charged, it’s been a reasonably usable router.

I used the same power connector into the other router, a Beryl, and it boots fine. The Beryl is a MAJOR PITA to keep connected to the phone. Regardless of the cable, it constantly drops and reconnects. But, it DOES boot. 'Course it won’t keep any of the phones charged either, but today’s crisis du jour is getting the AR750S up and working…

The GL-AR750S-EXT has a USB 2.0 port, which has the specification/standard to provide up to 5V/0.5A for 2.5W:

The USB 2.0 port is not intended to be a charger, only to power basic devices such as USB sticks and dongles that were available at the time the specification was developed. Powered USB hubs are intended to provide more total power when connecting 1 or more USB devices.

Smartphone manufacturers design their own dedicated adapters for their own devices to provide the necessary charging power, which may be 2A/10W or more.

Right. 'Cause nobody would ever plug a cell phone into the router… Either way, THAT’S not the number 1 problem at the moment. That’s just an admission in another topic that “Oh, well, our engineers will make the next version have enough passthrough to keep the cell phone that’s providing the signal functional.”

SO, tried the 10-second reset – as I understand the instructions, hold reset, plug router in, sit for 10 seconds… In this case, the only thing that happens is the power LED blinks very slowly. Which is what it has been doing for the last 24 hours.

Tried the UBOOT…
Step 3 says the “LEDs”, plural, will start blinking. Nope.
Then it says set the computer to There’s nothing there. I presume they mean IF the reset worked and the LEDs are blinking?
I presume everything after this as far as Uboot, is useless.

So, HOW do I get this thing to come back to life and boot?

That’s why smartphones have batteries and not designed to be tethered beyond the battery life!!!

Actually, I expect many more people will tether to a laptop for temporary use, instead of a router.

Regardless, my intention was to provide accurate information to other readers.

Cheers and good luck!

Still waiting for an answer on how to get this working…

This is not correct reset. 10 seconds reset is when the router is powered up completely. You operation make the router boot into uboot mode.

For uboot, you can also refer the the video gives very detailed guide How to Use UBoot to Debrick Your GL.iNet Router 2021 - YouTube
It shows for each model how to boot into uboot mode.

Thanks for the information. I ALMOST got it to work… I got to the Uboot and gave it the current file 3.211 for the AR750S. It would start updating and after about 10 seconds throw and error and quit. Something about size.
I went back a version to the August 2021 version 3.203 and tried that. It worked. Eventually the router rebooted.
Went int and got to the Admin page for the GL-AR750, where it demands a password. The only passwords I have are the one that’s ON THE BOTTOM of the router “goodlife” and MY PREVIOUS ONE. NEITHER works. It throws an error that the password is wrong. I can SEE that it has “goodlife”, exactly as it is on the bottom of the router in the Key field. Is there some OTHER password I should be putting in there? Did they CHANGE the default password?

Things have now composted. I unplugged the router after it told me the “goodlife” password was incorrect, plugged it back in and let it reboot. I have all 3 green lights on.
It’s connected to the computer with an ethernet cable – exactly the same setup I had during all the firmware updating.
Last time, I opened a browser, tried and and NEITHER connected. I tried and it DID connect. But it told me the password to even get in far enough to CHANGE the password was incorrect.
NOW, entering does NOT connect.
I can SEE the two wireless connections GL-AR750S-a23 and GL-AR750S-a23-5G, but BOTH require a password I don’t have.
Do I have to do something else I don’t know about to get the browser to connect? I reset the adapter to automatically get the IP address (ipt/4? from the video), and it originally connected. Now I can’t get it to even connect.


Sounds like you have a working router and just need to reset the router for some reason.

  1. power up the router till all three lights are working
  2. press down and hold the “reset” button on the right hand side
  3. the left hand led (power) should start blinking
  4. after about 5 blinks the power button should start blinking faster
  5. after about 5 more blinks the power button should start blinking even faster - release the reset button
  6. LEDs will all turn off

This should take you router back to factory default.

Leave until all three leds are lit again

Hopefully you can then see your two wireless connections again. Connect to one of them. The default password for the WiFi is “goodlife”. You should then be able to open a browser and go to (try using a private/incognito tab) and get the start page where it will ask for language and then ask you to set a password.

You can refer to the setup guide found here

Hope this helps.

Thanks for your patience… I have NO idea what I did differently. I did the Reset through the slow blinks, the medium blinks and into the fast blinks and released it after 10 seconds.
I connected to the wireless and put in goodlife.
It refused to connect.
I did it AGAIN with the same results.
Tried doing the connection from the desktop computer - it saw the SAME 2 wireless connections, and got the same login error on “goodlife”.

Went BACK to the laptop, which is still connected to the 750 via Ethernet, opened the wireless again, clicked on the connect and it connected - DIDN’T ask me for the password again, so that has to have been correct the last time…

SO, I’m in, and the Admin password has been changed…

I have absolutely NO idea why ONE firmware - the older one - would work and the current one NOT. I tried several times, got the same error every time.
OR why it wouldn’t accept the wireless connection until the 3rd or 4th attempt with multiple resets and reboots.

BUT, provided I DON’T screw anything up with setting it up - I have those instructions from when I did it the first time a couple years ago, so we’ll see.

Thanks again.

After WAY more messing around and messing up, I FINALLY have the wireless hooked up.

BUT, there’s one more thing that has to be done. There’s a piece of text that needs to be added to the custom rules for the firewall…

According to the instructions, I log in to the admin panel, click More Settings, click Advanced, and I’ll get a screen that looks like this:

Unfortunately, I get THIS:

Never had to INSTALL anything before. Do I install Luci?

Just click the button and install it.

I finally found a note somewhere that SOME routers come with it installed and some don’t. Apparently with this version of firmware the AR750S is now one of the “Don’t”.

At this point everything is working though only on CERTAIN USB plugs. Not sure WHAT’s up with that, but I’ve got a LOT of spare 2A, 2.4A and 3A usb adapters I can try.

OK, one problem solved, new one happening…
Router boots, cell phone connects, tethering comes on, happy happy.
At SOME point - could be a couple seconds, could be a couple minutes, but it won’t be long before the router crashes and reboots. Doesn’t appear to matter if I have a computer connected or not, but sometimes I can watch it reboot over and over and over.
All the phones are in Developer mode, and have USB debugging turned on (not sure why, but it was recommended). I’ve TRIED having “phone always on when connected to charger” turned on and that didn’t make any difference.
Yes, I’ve tried different power supplies.
Yes, I’ve tried different cables.
Yes, the connection from cell phone to router works - trust me, I’ve gone through a half dozen cables to find one that seems to make it happy.
I’ve used a power meter on the cable to the phone. The router NEVER puts out more than .4A, and most of the time the meter show 0, which is why the phones go dead after a while, but when the router is UP, there’s usually somewhere between 4.6 and 4.8 V coming out of it.
On the input side there’s 5.1 going in, so it’s NOT the power supply.

I’ve currently pulled the AR570 OFF the phone it was connected to, and switched it to a DIFFERENT phone that has completely different cables. Maybe it just doesn’t like the Moto G7 Power?

I’ll see how it does attached to the other phone ZTE Prime A7 that’s strictly a data phone.

So, even though this thing sort-of came back to life is it shot, or what?

So does other phone work?

SO FAR, yes. It’s been connected to the computer overnight, and as near as I can tell, it hasn’t crashed…

Next I’ll use these same cables and switch to the other phone. If it starts acting bizarre it’s the phone. If it works, it’s a cable… I don’t know WHAT it is about these cables - I have SS10 cables (USB 3.1 or 3.2 or whatever SS10 cables are. If THOSE don’t work, nothing’s going to. For power I’m using cables I’ve verified will pass a minimum of .8A, and most will pass at least 1.3A - this is putting the meter at the power supply then connecting the router. I HAVE some cables that won’t pass more than around .44-.48A, and the routers won’t even boot with those in use.
So, ALL the cables I’m using are a WHOLE LOT better than anything that should be required for this job…

1 Like

I’m starting to have the horrible feeling that at least PART of the problem is the Type-C charging port on the call phone. OR the type-C connector on some of these “really great USB 3.2” cables!

Yesterday, I used the cables that normally connect the data-only phone (ZTE A7) to the Moto G7. And it worked fine. These are NOT super-high ANYTHING cables, just normal, USB 3.0 (maybe 3.1) cables.

Til I wiggled the plug in the phone. Boom - off. Pulled it out, plugged back in, been working fine. I’ve wiggled it, jiggled it, poked it, pulled it, and NO problem.

I won’t get a chance to mess with it this weekend, but SOME cables appear NOT to be “wiggle-able” and others if you wiggle them, lose the connection. I may have to do a “test-off” to see which one’s AREN’T reliable, but I already know, the fattest, most expensive, great-ever, stiffest, USB 3.2 cable I have isn’t worth a puddle of spit as far as connecting the phone to the router! It APPEARS to work on a lot of OTHER stuff, but not well for that.

1 Like

I found over the weekend that cables matter - NOT because they don’t pass data, but because some of the type-C plugs can wiggle more in the phone socket. Not ALWAYS, but sometimes, moving the plug a tiny bit causes the connection to drop. I have a COUPLE cables that seem to fit pretty well, so those are what I’m using right now.

The PROBLEM is the Moto G7 is used as an actual PHONE, which means it “frequently” gets unplugged and goes off to use. Then I come back and plug it back in. The OTHER set - the data phone, NEVER gets used for anything else. It just sits there for weeks at a time, plugged into a router. Other then when it completely discharges because the routers won’t keep any of the phones charged, it doesn’t get unplugged.

SO, at the MOMENT, the AR750S is working, and has been, and with luck it’ll stay intact and functional for a while.