GLAXT1800 shows connecting, but not connected

Trying to connect my son’s desktop computer through ethernet port which does not have wifi capability or a wifi adapter installed and via LAN on the DL device. Continues to show “connecting” to our Spectrum internet’s wifi base (in another room), but his computer does not connect from the set up/admin page. We clicked the repeater option, but it’s not working. Not sure what I’m missing or if there’s a setting I don’t have checked.

Unless you have a specific need to connect inbound from your LAN to your son’s computer, the cleanest solution would probably be to leave the gl-inet device in router mode and have it connect to your wifi - then disable all of the wifi networks on the gl-inet device for better performance.

I assume your Spectrum network has a wifi password enabled - did you get those settings correct in the gl-inet dialog to join the network?

Thanks! Are you suggesting that I select the router option for the GL device? That’s what we chose from the onset. I do have the correct password for our internet/wifi entered in under the settings. It just says “connecting”, but not connected and doesn’t connect. When I load Chrome or MS Edge, it prompts us to run a diagnostic test since there’s no internet access. To clarify, I have the GL device plugged in to one of its LAN ports to my son’s ethernet port on his non-wifi’d computer.

Do you mean I need to connect all of the wifi networks that show in the list? We live in a neighborhood and there’s about 10 other networks that show besides ours.

(The GL router sees the spectrum Wifi network, so shouldn’t it be plug and play? It looks like from one of the YouTube videos for the ethernet choice of 4 possible connections, I need to plug directly into our Spectrum modem that supplies the internet, but that doesn’t make sense because then I would just run a 60 foot cable from the ethernet port from that to my son’s computer. We’re trying to avoid running lengthy cables through the house.)

All of this is being done through the admin panel/Internet. What should the settings be under wireless on the GL device under Wireless from the admin panel? Should that be enabled or not? Right now, both the 5G and 2.4 in that section are enabled. I feel like I’m missing a basic set up configuration. It should be working :).

From a bone stock device, you’re going to want to:

  1. Plug your son’s computer’s ethernet port into one of the LAN ports on the GL device.
  2. Go to the GL device’s firmware (
  3. Initially you won’t have any access. In the “Repeater” block, click on “Connect”. This will bring up a list of networks in your area.
  4. You can either select your network from the list that pops up, or click “Join other network” and enter your info there. In either case, make sure the SSID (network name) is correct, select the security type (probably WPA2, if it’s not already selected), and enter in your password. Click connect.
  5. You should, shortly, get an IP. If you don’t I would suggest removing the network and starting over from scratch.
  6. (optional) Click on the settings (the gear icon) and connect select the 5G (instead of mixed) network for better speed. Assuming you’re close enough to have a good connection.

If that doesn’t work, post back and we can go from there.

Thanks, I’ll try that. (The internet modem/wifi is about 60 feet away from his room where his computer is.)

It’s still not connecting :confused: . Not sure what to do. Thanks for your help!

If you’re able to get into the Spectrum box and mess with settings -

  1. Check what the bandwidth is on 5G for the Spectrum. If it’s at 160, try to turn it down to 80.
  2. Check what the WPA method is. If it’s dual-mode WPA2/3, try to just choose WPA2.

What model of gl device are you using? (edit: sorry… responded on my phone and didn’t see the pic. Upgrade to the latest firmware and see if that helps. The AXT1800 is… uhh… not the most bug free in terms of early firmware).

p.s., if that doesn’t work a more stock build with Travelmate might. I can help you through that if necessary.

I see that your firmware version is 4.0.3. This version may be a little long. Can you upgrade the latest firmware to test whether it can be connected? GL.iNet download center

Thanks, I updated/downloaded the new firmware to 4.1 and it still gives the same “connecting” with no connection message. I rebooted computer, signed into the admin panel again, double-checked the wifi SSID and password, called Spectrum, my ISP, and there’s nothing blocked on my end. I also tried it on my MAC and shut off that laptop’s wifi to try the repeater and I received the same message as my son’s PC desktop. Not sure what else to try or do. I appreciate everyone’s help, but it looks like I will need to return this device. (We do get an internet connection on this device through the ethernet connection with the WAN line connected to the Spectrum wifi router, with a LAN line running to my son’s computer with the super long Cat6/ethernet cable in the other room where the wifi router is. However, that’s the same as us just running the 70 foot cable from his ethernet port to the Spectrum wifi modem without the GL device. Was trying to avoid running long cables.)

Are you trying to connect to the Spectrum wifi over IPv6, which is shown in your photo?

Can you also test if it connects when closer to the Spectrum wifi (10-15 ft)? If it still does not connect, then post the System Log that may have error messages.

I do not work for and I am not directly associated with GL.iNet

Thanks, yes, I was trying to connect to the Spectrum wifi over the IPv6. When I tried on my Mac laptop, I was about 3 feet away with the GL box to the Spectrum wifi router…I’ll try in the morning - my son is sleeping now :).

Can you turn off IPv6 and try connecting over IPv4, if that is possible on the Spectrum router?