GLDDNS not workng with Wireguard connected

Does anybody knows how to make this work? If VPN is active then GLDDNS won’t work. I have read that I have to check for port forwarding but no luck. Flint router.

If your GL.iNet router is behind another router, such as from your ISP, that test is not reliable. On a Windows PC or Mac, run the nslookup command on the DDNS domain name to see if it resolves to your public IP address.

I do not work for and I do not have formal association with GL.iNet .

It’s resolving to my public ip address given by the vpn.

I enabled “Services from GL.iNet don’t Use VPN” from vpn dashboard global options and now getting this.

Is the hidden IP address the WAN IP of your GL router?
How does your GL router access the Internet? Is it connected to an ISP router?