GLinet 6416 tethering problem

problem trying to tether to a driod fone using easytether…connection established is good, ifconfig shows the tap-easytether interface…i am able to download update firmare (2.25) worked great, but no selections ‘tethering’ dropdown box…i have tried all the ar71xx apks…ssl and no crypto…lost right here…

Do you mean in 2.25 there is no connect but there is when using older version?

As I know the firmware doesn’t support easytether. Did you install software in the router by yourself?

amazingly it works…however, it doesnt show ANY phone devices available in the tethering dropdownbox…

i manually added a

interface ‘wan’

option ‘tap-easytether’

option proto ‘dhcp’


and it works…but doesnt show any phone tethering

i used one of the openssl .apk from the ar71xx files available at mobileStream for openWrt 15.05

i.m happy but wondering if it will last…




I see. We didn’t support easytether in the UI.

ifconfig now shows…
tap-easytether Link encap:Ethernet HWaddr 02:00:54:74:68:72
inet addr: Bcast: Mask:
inet6 addr: fe80::1082:b4ff:fec3:a46%eth0/64 Scope:Link
RX packets:130755 errors:0 dropped:0 overruns:0 frame:0
TX packets:111187 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:139687374 (133.2 MiB) TX bytes:10820809 (10.3 MiB)


i used one of the ar71xx files from here–

and had to manually add easytether to /etc/config/network

config interface ‘wan’
option hostname ‘GL-iNet-e5e’
option proto ‘dhcp’
option ifname ‘eth0’
option peerdns ‘0’
option custom_dns ‘1’
option dns ‘’

config interface ‘wan’
option ifname ‘tap-easytether’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’

i’m working thru it right now…works good so far, just doesnt display any thing for tethering under ‘settings’

just shows the IP

I can’t even get that far with the GL-MT300A.

I installed the openssl version for ramips/mt7620, added the /etc/config/network entry for tun-easytether. But running easytether-usb errors with in “Searching interface: not found” and tun-easytether is not found in ifconfig. Any ideas, KC7ON?

btw, is that a callsign? I’m KF5RCA.

Hi OM… yeah its my old call letters from way back…

I would try more .apk files till one works hopefully…at least start there…i went thru several before

success… its been work faithfully ever since…i have 6416 so ur mileage may vary…