Glinet WebUI= Change DNS Custom Server and put it in the VPN menu?

Hello!
I know that maybe it is silly and many firmwares have passed ahead, but it seems more logical to me to put the DNS Custom Server, instead in More Settings menu, to put in the VPN menu, since it is related to internet privacy, don’t you think?

For my part, I have to open VPN every time and then go to More Settings menu>Custom DNS Server to activate DNS Rebind (I have to deactivate every time because Caption Portal) and other functions that seem to help me maintain my privacy on the internet.
Thank you.
Bye!

You can put the dns in your ovpn files. When vpn is connected it will take priority to the customized dns settings.

Thank you alzhao but what I was asking is a way to put entire web menu DNS Custom Server in the VPN menu in gl.web UI


to HERE

Thank you

OK just made myself, quite easy, Thank you

Now I will try to put Green Dot when On/Off

OK. I got you. Interesting but you made it.

Yes, I think this menu is more related to internet security, so for me more sense to be in VPN menu than in More Settings menu.

When connected to the internet,I always have to make VPN first and then go to More Settings>Custom DNS and then put DNS Rebind ON.

I have to log on in a Caption Portal (that allows me to go to the internet, only one company in my country, only one way to go to the internet), so DNS Rebind have to be always disabled first. And I have to do it all in reverse to log off from Caption Portal.

So DNS Custom is better for me in VPN menu. :wink:

Bye

1 Like

How did you go about it?

could you please explain how you got it resolved?

Hello! I edit with WinSCP the following file here:
(make file backup in your pc always)

root/www/source/temple/index/index.html
and found in MORE SETTINGS this section:

li v-show=“routerMode == ‘router’ || routerMode == ‘mesh’”>
<a @click="$router.push(‘dns’)" class=“clsLink2dns bar”>
{{t($lang.index.customDns_ss)}}
cut it and put it in VPN section. Look carefully to keep with it the beginning and the end
<li> and </li>
It is working ok but it sends you to the More Settings Menu indirectly.
Bye

				<li v-show="routerMode == 'router' || routerMode == 'mesh'">
                                    <a @click="$router.push('dns')" class="clsLink2dns bar">
                                        {{t($lang.index.customDns_ss)}}
                                    </a>
                                </li>
1 Like

Thank you! :+1: :+1: