Glinet Xe300 Novotel Not working

I bought an xe-300 so I could use WiFi on multiple devices in hotels where they limit device numbers. I’m visiting a number of countries.

Not cheap, but thought it would be worth it.

First hotel I’ve gotten to has a limit of three devices, we have five. Perfect.

But, try as I might I cannot get the device to pass through the log on page.

Followed everything on here;

Mac cloning of the phone, WiFi cloning, using the hotel’s lan connection…tried resetting wifi, no matter what I do I go to logon to the WiFi of the device and it asks for authentication (“This site can’t be reached at”)

I’ve tried connecting from two different devices as well, reset the box twice and stared from scratch (the second time having connected the phone I’m cloning to the hotels WiFi prior to cloning)

I have DNS rebinding protection on etc.

Any tips or a better walkthrough?

Right now I’m not entirely sure why I bought the device, the whole point was to give me access for more devices.
I’ve sat here for an hour, no joy!

Firmware 3.216 (latest) btw. No VPN.
Yes, it says wlan connected (or cable when I connect that). Just no successful passthrough


You need to disable this option, not turn it on. :slightly_smiling_face:Just to make sure

If the problem still cannot be solved, I suggest you try the bridge mode

Ok, tried it with and without. Same result.

Sadly I’ll be leaving here this morning without any success at all in doing the job that I bought this device for.

Also I discovered yesterday how abysmal the battery life is.
Thought at least I could use it as a portable device for a day to share a single data SIM. But battery life is barely a few hours. Useless.
May as well use a hotspot on a phone.

Really very disappointed by this product after being happy with both my Glinet ar300 (both of them!) And my a1300.

I’ll give it another go at some point, I’ll have to to avoid feeling like this was just burning cash, but right now the x300 feels like a total and utter waste on money.
And a lot of money at that