GLS-1300 Not Recognizing Internet On WAN Port

I had to do a factory reset while setting up a new GLS-1300, after the factory reset it’s no longer recognizing the incoming internet on the WAN port. I know the incoming internet connection is working because I can plug it into the old router and it works fine. I have toggled the WAN/LAN setting and it has no effect, I still get the no connection error message.

Because it can’t detect the connection I don’t have the option to choose DHCP and release any existing connection. Any help would be appreciated.

Can you ssh to the router and get logs?

swconfig dev switch0 show

I was trying to get everything working and setup before I removed the existing router from it’s mounting on a sheet of pegboard, so I took the incoming internet and connected it to a network switch and connected the new router to the switch. For some reason it couldn’t “see” this connection, once I plugged the incoming internet directly into the new router it worked as expected.

1 Like

Is the router connecting to a modem? If yes then you should not connect a switch in between.

Modems checks mac addresses etc. If you change one router, you need to reboot the modem. Sometimes a reboot may not solve the problem immediately and you may need to wait hours for the modem to accept a new router. Or just call your ISP customer service and ask them to reset your modem.