Goodcloud port forwarding for End to End

I have a Slate that I’m trying to connect up to another slate on a different networks in an End-End configuration. Both are visible outside the local network verified by the DDNS test. Both are seen by good cloud in the device list. However, they are both NAT’ed behind the router that the internet provider provides.

I’m trying to configure port forwarding on my Netgear router for the Slate that I want to be the “master”. I can’t seem to get it to work.

Please verify what the port forwarding settings should be. Static LAN address for Slate router. TCP and or UDP routing? Port 51830? Any other ports needed?

Can port triggering be used also? UPNP? If the Slate had UPNP for the End-End head end, set up would be much easier.

Thanks. Mark Simon wd9jen @ aol ,com

Port forwarding
Protocol: UDP, TCP&UDP also worked
Port: only 51830
don’t support UPNP
Also need to make sure the internet provider has assign you a public ip.
I will send email to you.