Goodcloud site to site - Unable to access clients

Hi. I have set up a site to site goodcloud network using 2 Mango V2. One has public IP; it is OK, it is working with 2 nodes (main node and node 1). I want to access a client (ie domotic web server) behind the mango in node 1. Is it possible and how to do that ? Thanks.

You need to add the IP of your domotic web server in your goodcloud S2S control pannel.

To add IP in Goodcloud S2S control panel, is it the add box in “Configure LAN IP and Access Control” ?

Yes it is. Pls try and see.

Thanks. But not understood and still not working after several attempts…

Can you draw a picture of your network topology?
And some screenshots of Site to Site.

Here is a picture of the network. It freezes when connecting to web server. I can acceess screen for identification of user and password, but freezes just after. I have tried with two different web server (IP cam and domotic server). Problem is the same, freeze just after having enter identification and password in the web server. Any solution ?

Do you mean accessing the web server on the right side?

Maybe you can enable developer mode (F12) of your browser to find out what is going wrong.

On your left side, you have port forward 80 to lan I have no idea of why you set up like this.
First, you should not use 80 as it is used by the router itself.
Second, you should not forward to another subnet. You should only forward it to its own subnet (10.x)

Many thanks for your answer. I mean accessing the web server on the left side, because there is no public IP on the right side. Accessing from the left side is, I think, the only way to do it. May be I am wrong… I have forwarded port 80 on the left side to IP webserver because webserver uses port 80. I understand that I shoudn’t forward to another subnet, but in that case, how to access the web server on another subnet from the left side ?

Because it is managed S2S setup, you should just add which IP you can access from GoodCloud.

You should add in Node1 on Goodcloud and you can access it directly on the left side. Do not set up any port forward etc.

Thanks. But when I add in Node 1 on GoodCloud, system answer “Incorrect IP format” …

Here is the screen

From your network topology

You don’t need to do Port Forwards and Open Ports on both two GL-MT300N-V2
And you don’t need to Port Forwards 80 on Router FTTH, you only need to Port Forwards 51830 (default port of Site to Site) on Router FTTH(I think you already done this).
You don’t need to add in Node 1 on GoodCloud.
That is it.

If it still don’t work, please let me know.


Many thanks for your answer. I have cancelled Port Forwards and Open Ports on both two GL-MT300-V2. I have also cancelled Port Forwards on FTTH router except port 51830. GoodCloud site to site is OK.
I still can’t access the webserver… Question : what is the IP address to enter in the smartphone webbrowser to access webserver See new nerwork picture attached.

From your network typology. Your smartphone is connected to Router FTTH.
Could you try to let your smartphone connect to the WiFi of GL-MT300N-V2( ), and use its web browser to access

Thanks++. I have connected for test purpose my smartphone directly to the wifi of the GL-MT300N-V2 ( Access is OK (to and works fine. When using the web browser to access, I get the identification screen of the web server with user id and password. But after having entered ID and PW, no answer, browser freeze.
The problem is the same whatever the web server is; It is the same pb with an IP camera webserver or an IP domotic web server …

It is weird, it should work.
The webserver, you said it is an IP Camera, what is the brand and model?

Hi. IP camera is a D-Link 930L. Domotic webserver is Cartelectronic WES (Web Energie Superviseur). See . Problem is the same for both devices. Access is OK up to identification screen. Then freeze after having entered ID and PW. Devices are on port 80 and 8080.

I just send a Message to you, give a device info to add to your Site to Site network.
I am not sure whether the Site to Site is worked with an IP Camera.

I search the D-Link 930L, it has an App to watch the camera from anywhere, so why you want to use Site to Site to watch the camera?