Google still shows my real IP when others don't..?

Hello, I just bought a GL-SF1200 58D router. It is connected to my ISP modem/router through a LAN cable, and acts as our Wi-Fi router instead. It is connected to Proton VPS wireguard client and is connected to their servers. My IP address shows where my VPN is routed to if I go to any whereismyipaddress.com type websites, as well as dnsleaktest.com. However, when I open up chrome and do a google search, google shows my real IP address at the bottom and shows where I am coming from. This tells me that it is not correctly set up and my information is leaking somehow (which is the exact reason why I bought this modem, so this will not happen). In the admin panel, it shows that I am connected to the VPN in my wireguard client profile, and I can see the upload/download transfer rates, so I am apparently connected. Also, when I activate the killswitch in my admin panel, it shuts down ALL of my internet immediately. I would like to know how I can fix this, and how to properly set up a proxy server directly in my router if I need to use a proxy. I’m running on Windows. Thanks!

For this problem, can you open a Incognito window and check again?

1 Like

Try flushing you DNS in chrome and on you computer.

Windows: Press Win + R and run cmd. Execute command ipconfig /flushdns.

MacOS: Open Terminal and execute command sudo killall -HUP mDNSResponder.

Ubuntu: Open Terminal and execute command sudo service network-manager restart.

You may also need to clear DNS cache in your browser.

Chrome: Visit chrome://net-internals/#dns. Click Clear host cache.

Firefox: Open Firefox and press Ctrl + Shift + Delete. Select Time range to Everything and check only Cache. Finally, click Clear Now.

2 Likes

I went to VPN policy, enabled it and chose my device MAC address from the list and added them, then chose “Only allow the following use VPN”. That seemed to help on my PC. However, my android devices went on airplane mode, and connected only through the WLAN. Google is still showing my real location on my android devices, and my GPS/location is shut off, as well as cookies/cache/browsing history is completely cleared. whatismyipaddress. com shows my VPN location, as well as dnsleaktest. com. However, iplocation.net still reveals my real IP address along with google. All my google accounts are also logged off my phones. Also, when killswitch is enabled, it still shuts off the entire internet on the network, which shows something still isn’t quite right. :frowning:

You need to go full tin-foil-hat and remove the GPS module from the control board. :joy: Depending on the phone manufacturer you need to turn all GPS location apps off (flashlight was notorious for gaining access to everything on phones and is one example) , even then it could be getting general gps from other routers. Bluetooth could also be used for location. Cellular 5G can also triangulate locations very well and could be receiving signals but not transmitting.

You could try isolating it in a Faraday bag and connect using a ethernet to usb C cable.

1 Like

Haha! They are all Samsungs, all the GPS options are set to off and no apps are allowed location permission. All the cache and history has been deleted. Bluetooth is also off. I’m on a 4G network. I’m also using it on airplane mode. Google says my real location is “based off of my IP address.”

Incognito mode doesn’t change anything now, google says at the bottom where my location is based off of my IP address. Iplocation.net also shows my real IP address.

Thanks! I did all of this, and restarted chrome on my windows 10 pc, and google still shows my location based off of my ip address. iplocation.net also shows my real IP address. :frowning:

None of this has worked, and still haven’t found a solution of why I lose 100% connection when I activate the killswitch. When I go into VPN wireguard client, it shows that I am connected to my profile and I see the download and upload data moving and says that I am obviously connected to the vpn. In VPN policies, I still have “Use VPN for all processes on the router” activated, MAC address activated, “Only allow the following use VPN” activated, and I see my devices listed on there. When I activate my VPN software/app on my PC and Android devices, it works like it should, but the point is to secure the entire connection to the home wi-fi to the VPN regardless of which device is connected through its own app. Including 2 xboxes, which obviously dont have a VPN app.

I tried Proton Wireguard.

I treid

whatismyipaddress.com

All shows my VPN IP.

Chrome shows my real location and it is said from my device. That is because I logged my Google account in my phone.

If I use incognito mode in my chrome and it changed the location.

image

Tried a different Wireguard server.

image

But if I allow Chrome to get my location (even in Incognito mode) it can shows where I am. I think it just read the location from my device.

So everything just works in my side.

Can you let me know how do you generate the wireguard config or just post the config to have a check?

1 Like

Thank you so much!! I believe I downloaded the wireguard configuration for windows (thinking that I was using windows) instead of the code for the router. Now it seems to be fixed. I appreciate the help!

1 Like