GUI fails to generate Tailscale bind device link on firmware 4.6.2

The title says it all. The page remains on "Processing, please wait…" forever.

Getting the bind link from the terminal is not an option because the router in question is remote and rtty through Goodcloud also fails (gives a grey screen).

It works for me

Do you have VPN etc. configured?

Yes, but getting the device bind link from the GUI fails even while the VPN is turned off.

Except for vpn, anything else you configured on the router?

I tried a few combinations, e.g. adguard home, kill switch and it still works fine.

Did you update tailscale by chance?

Yes, using your script.

Try to revert it - same script, using --restore and try again.
Maybe the link generation is broken in on of the newest versions ...

In the meantime, I had thought of using Remote Desktop to get a shell on the remote router and then obtained the link using tailscale status.

But it is good to know your script can be undone. Is the complete command like this correct:

wget -O \ && sh --restore

Yup, should work like that.
Please refer GitHub - Admonstrator/glinet-tailscale-updater: This script updates the Tailscale installation on GL.iNet routers. for all available switches and commands.

Oh, that's cool that you put your script on Github. I even found the answer there as to why it hasn't been applying UPX compression recently.

Can confirm this is/was an issue. AX1800 with same result after script usage. --restore then ran it again after binding.