Handful of issues with brand new Mudi / GL-E750

After some thinking, I’ve decided to buy a Mudi for travel purposes. Previously, I’ve been using a RAVPower RP-WD009, but the lack of OpenWRT, support, and built in 4G was a bit of a deal breaker. I like the idea of having a small portable storage and router that provides a VPN uplink to my home server, though, especially that can sync content with my server for backup purposes.

However after a day of use, I have ran into multiple issues:

  • my microSD is not detected at all. It is a 128GB SanDisk Ultra SD card, with MTP partitioning, and a single FAT32 partition. All my other computers, and even the WD009 read it without issue. And by not working I mean there’s no block device, or any indication that an SD card was inserted
  • the connection is unstable, I often get dropped off of it, especially if I have an active SSH connection, or am installing OPKG software (either via the Gl.inet admin interface Plugins, or via LuCI, or via terminal)
  • mount and share management is atrocious. For a travel router that has been advertised as a file hub, I find it incredibly weird that all shares are automatic, the user has no control over it (unless they go through the trouble of installing LuCI and managing mounts, Samba shares through there), nor is there an interface to browse the files. If this device is to be a storage hub as well, it needs at least a file browser, and a minimal partition/drive/share manager (allow the formatting of a disk, creation of multiple partitions, assigning them to mount points, and creating shares pointing to specific folders, plus share right management).
  • AzireVPN login does not work. I made sure to insert the appropriate password, and even tried a token, all resulted in a “username or password invalid” - which is quite unlikely, since I copy-pasted the values from my password manager
  • The OLED display always show 3G/4G signal as full, even when the web interface shows a single bar of reception…
  • No IPv6 support whatsoever!
  • It would be nice to have a sort of SDK, or example, for development-oriented users to create their own gl dashboard views. As it’s been made apparent by the AdguardHome package, third party services can easily integrate, and I for one would love to have a few extra options for open source firmware.
  • No data limit visualisation and management on the dashboard (warnings, limits, etc.)
  • Quite slow throughputs sometime - especially with VPN, even if uplink is ethernet.

Is this behaviour normal, or is my unit faulty?

2 Likes

The SD card does not support hot plugging, so you must restart the device every time you insert the SIM card

The MUDI 2.4g and 5G SSID are the same. Usually, the interference of 2.4g will be larger. Are you connected to 2.4g or 5G?
If you can’t tell, you can set different ssids

Do you have any special characters in your username and password?

This could be a BUG.

We are developing IPV6 functionality.

You can refer to this link

You can try wireguard, which is much faster than ovpn

I’ve restarted the device multiple times, and even reset. I’ve inserted the SD card before turning it on OOTB. There’s no interface under /dev/ (although /dev/sda is automatically created on boot, without an actual device, meaning I can’t use cfdisk/sfdisk as they both panic trying to access it), and the card is simply not detected.

Also quite interesting that you couldn’t manage hot plugging on the microSD card, since it’s part of the interface definition.

It’s not interference though, as the connection drop only happens if the Mudi is doing something “resource heavy” (such as, installing a handful of new packages via IPKG, or applying a larger configuration for IP routes, etc.). It does not matter if I’m accessing the device through WiFi, or if I plug it into one of my router’s ethernet ports. It’s like the device does a “soft reboot”, all networking is dropped for a few seconds, WiFi disappears, etc.

None, just alphanumeric characters.

It most definitely is a bug. I’ve tried the 3.102 firmware, without luck.

That’s good to hear. My home network is behind CG-NAT, but has full IPv6 stack, so it’s easier for me to access internal stuff using an IPv6 connection (even if it is just to establish a VPN connection), than to hack my way around using e.g. ZeroTier.

Please do make sure that once IPv6 is enabled in the firmware, you also enable it in WireGuard configurations! Right now the manual form complains about the format (invalid IP error), and using the plain config uploader, the IPv6 values are dropped during saving.

I’m using WireGuard exclusively at the moment. Much easier to set up than OpenVPN, less taxing on the hardware, and generally, a nicer experience.

That site gives info on the API, yes, but it offers little about how to create an IPKG that adds extra menu options on the GL.inet admin panel.

Since the router UI is closed source, you would have to edit the HTML code of the UI and add your menus there manually.

GL had to develop the UI to add Adguard, it wasn’t just an IPK install.

The UI is built of separate elements, and it is possible to add extra items using an API - at least as a developer, I’d presume so, since otherwise developing all the separate pages would be a pain in the ass. The fact that installing e.g. the e750-mcu package adds a menu item makes me think that there IS indeed an API that can be called to add a new menu item and point it at a certain resource to be loaded in the frame on the right side.

The AdGuard interface is nothing more than an iframe pointing at the actual dashboard of AGH.

Yeah, but none of that you said is open source so :slight_smile:

End users just have to edit the HTML and Javascript manually :slight_smile:

The API could be opened up, though. GL.inet makes enough models that it fits the needs of a lot of people, many of those are developers. I for one would love to add a ZeroTier config interface, proper SAMBA configuration, and whatnot, all based on the open source LuCI packages. Hell, the API doesn’t even need to be that advanced, all it needs to take is the name of the menu point, and the page it should display.

And that is why GL keeps access to Luci. You are free to do all those things on the Luci interface, with a lot of support and examples online.

The whole idea of the GL UI is to do the basic tasks like wifi, connections, lan, firewall and vpn great for most users. For other more advanced things, Luci is the way to go.